Uploaded image for project: 'Apache RocketMQ'
  1. Apache RocketMQ
  2. ROCKETMQ-199

consumers can not receive stock information.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.0-incubating
    • Fix Version/s: 4.1.0-incubating
    • Component/s: rocketmq-client
    • Labels:
      None

      Description

      producers start before consumers and send n messages to the broker.then a consumer subscribes to the same topic but tags do not match.the unexpected consumer did not receive any information.then start another consumer,and he subcribes to the same topic and the tags match.why still can not receive the news?

        Activity

        Jaskey Jaskey Lam added a comment -

        This is actually not a bug in current rocketmq design.

        In current desgin, rocketmq requires that the instances in the same consumer group should have the same subscriptions, that is the same topic and the same tag, or some unexpected issue will occur.

        You should make your consumer have the same superscriptions or make belong to different consumer group.

        A enhancement for this restriction has been issue in https://issues.apache.org/jira/browse/ROCKETMQ-94?jql=project%20%3D%20ROCKETMQ

        zander dongeforever added a comment -

        Since another issue will handle this problem.
        This one should be closed

        zander dongeforever added a comment -

        Since another issue will handle this problem.
        This one should be closed


          People

          • Assignee:
            vintagewang Xiaorui Wang
            Reporter:
            wowxhycoming@sina.com xuhuaiyu
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development