Uploaded image for project: 'Apache Rat'
  1. Apache Rat
  2. RAT-239

rat plugin fails in mult-iproject build when subproject has surefire-plugin forkCount=0

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 0.12
    • None
    • maven, scan
    • None
    • OSX, Linux

    Description

      We have a project using the apache-rat-plugin:0.12 to verify licenses, and it suddenly started failing with a FileNotFoundException for a subproject file that certainly does exist. I have attached the output from the maven build and build with -X as build-ouput.rtf and build-outputX.rtf respectively.

      One can go into the tck subproject and run the build and rat has no problem processing the file from within that directory.

      After reversing changes to find what the cause was, it came down to the tck/pom.xml use of forkCount=0 in the maven-surefire-plugin configuration. I have know idea why this should affect the rat plugin, but it does.

      To reproduce the issue:

      1. git clone https://github.com/eclipse/microprofile-jwt-auth.git
      2. git checkout tags/ratbug
      3. mvn clean install

      Changing the forkCount to 1 or higher fixes the FileNotFound problem.

      Attachments

        1. build-output.rtf
          22 kB
          Scott M Stark
        2. build-outputX.rtf
          13.41 MB
          Scott M Stark

        Activity

          People

            Unassigned Unassigned
            starksm64 Scott M Stark
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated: