Uploaded image for project: 'Apache Rat'
  1. Apache Rat
  2. RAT-232

Removed prerequisites from pom use maven-enforcer instead

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 0.13
    • 0.13
    • None
    • None

    Description

      Based on a change in Maven 3.5.0-alpha-1 all non maven-plugin projects which are using

      <prerequisites>
      <maven>..</maven>
      </prerequisites>
      

      will produce a WARNING during a build. Better to force using a particular maven version using maven-enforcer-plugin.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            khmarbaise Karl Heinz Marbaise
            khmarbaise Karl Heinz Marbaise
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment