Uploaded image for project: 'Ranger'
  1. Ranger
  2. RANGER-1994

Tomcat Security Vulnerability Alert. The version of the tomcat for ranger should upgrade to 7.0.85.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1.0
    • Component/s: Ranger
    • Labels:
    • Flags:
      Patch, Important

      Description

      [SECURITY] CVE-2018-1305 Security constraint annotations applied too late

      CVE-2018-1305 Security constraint annotations applied too late

      Severity: High 

      Versions Affected: Apache Tomcat 9.0.0.M1 to 9.0.4 Apache Tomcat 8.5.0 to 8.5.27 Apache Tomcat 8.0.0.RC1 to 8.0.49 Apache Tomcat 7.0.0 to 7.0.84

      Description: Security constraints defined by annotations of Servlets were only applied once a Servlet had been loaded. Because security constraints defined in this way apply to the URL pattern and any URLs below that point, it was possible - depending on the order Servlets were loaded - for some security constraints not to be applied. This could have exposed resources to users who were not authorised to access them.

      Mitigation: Users of the affected versions should apply one of the following mitigations. Upgrade to: - Apache Tomcat 9.0.5 or later - Apache Tomcat 8.5.28 or later - Apache Tomcat 8.0.50 or later - Apache Tomcat 7.0.85 or later

      References:https://lists.apache.org/thread.html/d3354bb0a4eda4acc0a66f3eb24a213fdb75d12c7d16060b23e65781@%3Cannounce.tomcat.apache.org%3E

        Attachments

          Activity

            People

            • Assignee:
              zhangqiang2 Qiang Zhang
              Reporter:
              zhangqiang2 Qiang Zhang
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: