Uploaded image for project: 'Ranger'
  1. Ranger
  2. RANGER-1671

The admin service can't audit to Solr using Basic Authentication

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.0
    • Component/s: admin
    • Labels:
      None

      Description

      Although we have configuration items in install.properties to set a username and password for Solr, these are not actually used in the admin service:

      • audit_solr_user
      • audit_solr_password

      This means that if Solr is configured to require basic authentication then we can't audit to it.

        Issue Links

          Activity

          coheigea Colm O hEigeartaigh added a comment - Reporter

          Sorry, I still don't understand the problem here. If you want to authenticate using kerberos, then don't fill in values for audit_solr_user and audit_solr_password. What am I missing?

          zhangqiang2 Qiang Zhang added a comment - - edited

          Hi Colm O hEigeartaigh. When solr uses kerberos to authenticate, the audit_solr_user audit_solr_password is not invalid. They are different authentication mechanism.
          audit_solr_user audit_solr_password is basic authentication.

          In RANGER-1684 we resolved this problem.

          coheigea Colm O hEigeartaigh added a comment - Reporter

          Hi Qiang Zhang,

          Could you expand a bit on what the problem is? If you are using Solr with Kerberos then why would you configure audit_solr_user audit_solr_password?

          zhangqiang2 Qiang Zhang added a comment -

          Hi Colm O hEigeartaigh, Please test this issue carefully. The function to query aduit log maybe fail after opened kerberos.


            People

            • Assignee:
              coheigea Colm O hEigeartaigh
              Reporter:
              coheigea Colm O hEigeartaigh
              Request participants:
              None
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: