Details

    • Type: Test
    • Status: In Progress
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
      None

      Description

      I checked out QPID-IT and wanted to run it for myself. I decided to use Fedora 25 in docker, because I wanted to have a reproducible setup.

      I created a Dockerfile which installs prerequisites and QPID-IT. When I run tests, it always freezes after few tests.

      Is there anything wrong about the install?

      Steps to use the Dockerfile
      1) place the Dockerfile in the top directory of qpid-interop-test
      2) % docker build -t interop .
      3) % docker run --rm -it interop bash -c "/artemis200i0/bin/artemis-service start; sleep 10; export PYTHONPATH=/usr/lib64/proton/bindings/python/; export QIT_INSTALL_PREFIX=/usr; src/python/qpid_interop_test/amqp_types_test.py --exclude-shim RheaJs"

      Starting artemis-service
      artemis-service is now running (14)
      WARNING: AMQP DotNetLite shims not installed
      Test Broker: apache-activemq-artemis v.2.0.0-SNAPSHOT on <platform not found>
      
      test_binary_ProtonCpp->ProtonCpp (__main__.BinaryTestCase) ... ok
      test_binary_ProtonCpp->ProtonPython (__main__.BinaryTestCase) ... ok
      test_binary_ProtonPython->ProtonCpp (__main__.BinaryTestCase) ... ok
      test_binary_ProtonPython->ProtonPython (__main__.BinaryTestCase) ... ok
      test_boolean_ProtonCpp->ProtonCpp (__main__.BooleanTestCase) ... 
      

      And it stays stuck for quite long time. The output is the same every time I run this. I did not wait for long enough to see if it gets unstuck, I admit.

      If I run this with the 1.5.3 broker, meaning in step 3) I do % docker run --rm -it interop bash -c "/artemis153i0/bin/artemis-service start; sleep 10; export PYTHONPATH=/usr/lib64/proton/bindings/python/; export QIT_INSTALL_PREFIX=/usr; src/python/qpid_interop_test/amqp_types_test.py --exclude-shim RheaJs" then the tests seem to succeed, so maybe it is just incompatible with Artemis 2.0.0...

        Attachments

        1. Dockerfile
          4 kB
          Jiri Daněk

          Activity

            People

            • Assignee:
              jdanek Jiri Daněk
              Reporter:
              jdanek Jiri Daněk
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated: