Qpid
  1. Qpid
  2. QPID-912

AMQSession.getQueueDepth should better describe its failure conditions.

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Later
    • Affects Version/s: M2, M2.1
    • Fix Version/s: JIRA Cleanup
    • Component/s: Java Client
    • Labels:
      None

      Description

      Summary:
      There are a few things that could do with improvement with the javadoc:
      It suggests that it will retry in the event of failover. It won't... perhaps it should.
      It also declares the queue passively as a result if the queue doesn't exist then it causes the connection to failover.

        Activity

        Martin Ritchie added a comment -

        I don't have the detail of which QueueBrowser test this was but it shows the failover caused by the getQueueDepth call when the queue wasn't created. The concern that should be addressed though is the timeout that occurs shortly afterwards. It suggests that something isn't being notified correctly when failover occurs.

        Marnie McCormack added a comment -

        Descoping items not being worked on for M4 into Unknown Fix Version for now

        Robbie Gemmell added a comment -

        Closing issue out as part of JIRA cleanup. Issue may already be resolved, may be invalid, or may never be fixed. See QPID-3469 for further details.


          People

          • Assignee:
            Unassigned
            Reporter:
            Martin Ritchie
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development