Uploaded image for project: 'Qpid'
  1. Qpid
  2. QPID-8580

[Broker-J] Upgrade dependencies to the latest version

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Implemented
    • None
    • qpid-java-broker-9.0.0
    • Broker-J
    • None

    Description

      Upgrade Qpid Broker dependencies to the latest versions:

      • logback 1.2.11
      • logback-db 1.2.11.1 (before version 1.2.8 it was part of logback-core)
      • guava 31.1-jre
      • jackson 2.13.4
      • jackson-databind 2.13.4.2
      • jetty 9.49.v20220914
      • bonecp 0.8.0.RELEASE
      • commons-cli 1.5.0
      • asm 9.4
      • dojo 1.17.2
      • dgrid 1.3.3
      • mockito 4.8.1
      • netty 4.1.84.Final
      • maven-core 3.8.6
      • maven-resolver 1.8.2
      • nashorn 15.4
      • apache-directory 2.0.0.AM26 (there is a bug in 2.0.0.AM26 that prevents building on Java 17 - details DIRSERVER-2326)
      • kerby 2.0.2
      • bouncy-castle 1.70

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            orudyy Alex Rudyy
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment