Qpid
  1. Qpid
  2. QPID-5036

[Java Broker] View Message dialog fails to display persistance and expiration info

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.18, 0.20, 0.22
    • Fix Version/s: 0.24, 0.25
    • Component/s: Java Broker
    • Labels:
      None

      Description

      In the 'View Message' dialog in the web management console, messages always display as "Persistent: True" regardless of their actual persistence setting.

      Similarly, messages set with an expiration time display no value against the "Expiration" field.

      In the case of the latter, this looks to be a mismatch between the IDs in the attribute name in the JSON, and the HTML in the view.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        3d 1h 49m 1 Keith Wall 05/Aug/13 12:09
        In Progress In Progress Reviewable Reviewable
        8s 1 Keith Wall 05/Aug/13 12:09
        Reviewable Reviewable Resolved Resolved
        10h 46m 1 Robbie Gemmell 05/Aug/13 22:55
        Resolved Resolved Closed Closed
        33d 15h 41m 1 Justin Ross 08/Sep/13 14:37
        Justin Ross made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Justin Ross added a comment -
        Keith Wall made changes -
        Fix Version/s 0.24 [ 12324776 ]
        ASF subversion and git services added a comment -

        Commit 1513480 from Keith Wall in branch 'qpid/branches/0.24'
        [ https://svn.apache.org/r1513480 ]

        QPID-5036: View Message dialog fails to display persistance and expiration info

        svn merge -c 1510429 https://svn.apache.org/repos/asf/qpid/trunk/qpid

        Justin Ross added a comment -

        Reviewed by Robbie. Approved for 0.24.

        Robbie Gemmell made changes -
        Status Ready To Review [ 10006 ] Resolved [ 5 ]
        Fix Version/s 0.25 [ 12324777 ]
        Fix Version/s 0.23 [ 12324273 ]
        Resolution Fixed [ 1 ]
        Robbie Gemmell added a comment -

        Looks good to me, very minimal change which corrects the display of erroneous information about messages, I agree we should request this for inclusion in 0.24.

        Keith Wall made changes -
        Assignee Keith Wall [ k-wall ] Robbie Gemmell [ gemmellr ]
        Keith Wall added a comment -

        Hi Robbie, can you review this commit? If okay, I will request it be merged to 0.22.

        Keith Wall made changes -
        Status In Progress [ 3 ] Ready To Review [ 10006 ]
        Keith Wall made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        ASF subversion and git services added a comment -

        Commit 1510429 from Keith Wall in branch 'qpid/trunk'
        [ https://svn.apache.org/r1510429 ]

        QPID-5036: View Message dialogue can omit or display stale field values.

        • Fixed mismatched id between json and html (message-expiration vs message-expirationTime).
        • Fixed display of stale values (values from previously viewed message would appear).
        • Fixed display of fields with the boolean value false.
        • MessageServlet changed so that JSON fields expirationTime and timestamp are included if they have non-zero values.
        • MessageServlet fails to set content type when producing JSON for single message. This caused a "not well-formed" error in Firefox Console.
        Keith Wall added a comment -

        The issues are:

        1. mismatched id between json and html (message-expiration vs message-expirationTime).
        2. display of 'stale' values - that is, if I view a message with a message id, then view a message without, I see the message id from the previous message. This is caused by a scoping problem (the algorithm intends that populatedFields is shared state). Also clicking 'x' should clear the state.
        3. the algorithm fails to render boolean false values - this means non persistent messages show empty value for field (or the stale value from the previously viewed message)
        Keith Wall made changes -
        Description In the 'View Message' dialog in the web management console, messages always display as persistent: True regardless of their actual persistence setting.

        Similarly, messages set with an expiration time display no value against the "Expiration" field.

        In the case of the latter, this looks to be a mismatch between the IDs in the attribute name in the JSON, and the HTML in the view.
        In the 'View Message' dialog in the web management console, messages always display as "Persistent: True" regardless of their actual persistence setting.

        Similarly, messages set with an expiration time display no value against the "Expiration" field.

        In the case of the latter, this looks to be a mismatch between the IDs in the attribute name in the JSON, and the HTML in the view.
        Keith Wall made changes -
        Fix Version/s 0.23 [ 12324273 ]
        Fix Version/s 0.18 [ 12322451 ]
        Fix Version/s 0.20 [ 12323548 ]
        Fix Version/s 0.22 [ 12324272 ]
        Affects Version/s 0.22 [ 12324272 ]
        Affects Version/s 0.20 [ 12323548 ]
        Affects Version/s 0.18 [ 12322451 ]
        Keith Wall added a comment -

        Users may workaround this issue by using the JMX Management interface.

        Keith Wall made changes -
        Field Original Value New Value
        Description In the 'View Message' dialog in the web management console, messages set as NON_PERSISTENT display no value against the "Persistent" field.

        Similarly, messages set with an expiration time display no value against the "Expiration" field.

        In the case of the latter, this looks to be a mismatch between the IDs in the attribute name in the JSON, and the HTML in the view.
        In the 'View Message' dialog in the web management console, messages always display as persistent: True regardless of their actual persistence setting.

        Similarly, messages set with an expiration time display no value against the "Expiration" field.

        In the case of the latter, this looks to be a mismatch between the IDs in the attribute name in the JSON, and the HTML in the view.
        Keith Wall created issue -

          People

          • Assignee:
            Robbie Gemmell
            Reporter:
            Keith Wall
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development