Uploaded image for project: 'Qpid'
  1. Qpid
  2. QPID-5018

Mark deprecated APIs to issue warnings if used by applications.

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 0.24
    • Fix Version/s: 0.25
    • Component/s: C++ Broker, C++ Client, QMF
    • Labels:
      None

      Description

      QPID-4940 and QPID-4942 will remove public APIs on release of 0.26.

      For 0.24, it would be ideal to add some sort of notification when applications are built against these interfaces.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kgiusti Ken Giusti
                Reporter:
                kgiusti Ken Giusti
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: