Qpid
  1. Qpid
  2. QPID-4183

[Java Broker] AMQP 1.0 implementation broken by management adaptation layer

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.18, 0.19
    • Component/s: None
    • Labels:
      None

      Description

      The management adapters added to the broker break the AMQP 1.0 implementation as the implementaion of SessionModel and ConnectionModel is now required or else the connection cannot be properly initiated.

      Add a minimal implementation to restore AMQP 1.0 functionality

        Activity

        Rob Godfrey created issue -
        Rob Godfrey made changes -
        Field Original Value New Value
        Status Open [ 1 ] In Progress [ 3 ]
        Rob Godfrey made changes -
        Status In Progress [ 3 ] Ready To Review [ 10006 ]
        Robbie Gemmell made changes -
        Status Ready To Review [ 10006 ] Resolved [ 5 ]
        Fix Version/s 0.19 [ 12322452 ]
        Resolution Fixed [ 1 ]
        Rob Godfrey made changes -
        Fix Version/s 0.18 [ 12322451 ]

          People

          • Assignee:
            Rob Godfrey
            Reporter:
            Rob Godfrey
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development