Uploaded image for project: 'Qpid'
  1. Qpid
  2. QPID-4094

Qpid MC misformats JMX notification dates

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.17
    • Fix Version/s: 0.17
    • Component/s: None

      Description

      The Qpid Management JMX Console shows the user the date/time at which each JMX notification was created by the Java Broker.

      There is a problem with the date formatting which means the date displayed to the user appears to be wrong. The format is trying to be 24hour clock, GMT timezone. Testing in the UK in summer the date/times appear to be 13 hours out.

      The problem is with the date format string within NotificationObject. It uses hh:mm:ss dd/MM/yy z when it means to use HH:mm:ss dd/MM/yy z.

      Future management interfaces should not assume a locale.

        Activity

        gemmellr Robbie Gemmell added a comment -

        Looks ok to me.

        k-wall Keith Wall added a comment -

        Patch applied.


          People

          • Assignee:
            gemmellr Robbie Gemmell
            Reporter:
            k-wall Keith Wall
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development