Uploaded image for project: 'Qpid'
  1. Qpid
  2. QPID-4080

HAClusterWhiteboxTest#testClusterLosingNodeRetainsData fails occasionally on Apache CI

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Minor
    • Resolution: Fixed
    • 0.17
    • None
    • Java Tests

    Description

      Test HAClusterWhiteboxTest#testClusterLosingNodeRetainsData has been seen to fail on Apache CI (profile java-bdb.0-10).

      https://builds.apache.org/view/M-R/view/Qpid/job/Qpid-Java-Java-BDB-TestMatrix/337/jdk=JDK%201.6%20(latest),label=Ubuntu,profile=java-bdb.0-10/testReport/junit/org.apache.qpid.server.store.berkeleydb/HAClusterWhiteboxTest/testClusterLosingNodeRetainsData/

      Error Message
      
      no valid connection obtained
      Stacktrace
      
      junit.framework.AssertionFailedError: no valid connection obtained
      	at org.apache.qpid.server.store.berkeleydb.HAClusterWhiteboxTest.testClusterLosingNodeRetainsData(HAClusterWhiteboxTest.java:164)
      	at org.apache.qpid.test.utils.QpidBrokerTestCase.runBare(QpidBrokerTestCase.java:239)
      	at org.apache.qpid.test.utils.QpidTestCase.run(QpidTestCase.java:137)
      

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            kwall Keith Wall
            kwall Keith Wall
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment