Qpid
  1. Qpid
  2. QPID-3482

Unable to switch off logging to syslog when qpidd runs as daemon

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.10
    • Fix Version/s: 0.14
    • Component/s: C++ Broker
    • Labels:
      None

      Description

      When qpidd runs as daemon, it is impossible to switch off its logging to syslog:

      qpidd --log-to-syslog no --log-to-file /tmp/qpidd.txt -d

      causes logs go to syslog, while:

      qpidd --log-to-syslog no --log-to-file /tmp/qpidd.txt

      doesn't log to syslog.

      I think the issue is caused by -d flag overriding log-to-syslog option:

      Daemon options:
      -d [ --daemon ] Run as a daemon. Logs to syslog by default in
      this mode.

        Activity

        Pavel Moravec created issue -
        Alan Conway made changes -
        Field Original Value New Value
        Assignee Alan Conway [ aconway ]
        Alan Conway added a comment -

        Fixed on trunk r1170164

        Alan Conway made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Justin Ross made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        18m 51s 1 Alan Conway 13/Sep/11 14:00
        Resolved Resolved Closed Closed
        685d 5h 53m 1 Justin Ross 29/Jul/13 19:53

          People

          • Assignee:
            Alan Conway
            Reporter:
            Pavel Moravec
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development