Qpid
  1. Qpid
  2. QPID-3301

Remove support for ACL V1 (aka SimpleXML) from Java Broker

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.10
    • Fix Version/s: 0.11
    • Component/s: Java Broker
    • Labels:

      Description

      ACL V1s(aka SimpleXML) were superseded by the ACL V2 a number of Qpid releases ago. The V2 format supports all of the use-cases of V1, with a richer syntax, and is supported by both C++ and Java Brokers.

      This change is to cleanly remove the simple-xml broker plugin, associated system tests and v1 specific config files.

      Wiki pages will be updated to flag the fact that V1 is supported for releases <= 0.10.

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Robbie Gemmell
            Reporter:
            Keith Wall
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development