Qpid
  1. Qpid
  2. QPID-3182

node bindings not established correctly when address used for producer

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.10
    • Fix Version/s: None
    • Component/s: Java Client
    • Labels:
      None

      Description

      The behaviour in resolving addresses in JMS client appears to vary by context. Consider the following address:

      "my-queue; {create:always, node:{x-bindings:[

      { exchange:'amq.fanout', queue:'my-queue'}

      ]}}"

      This should result in a queue named my-queue being created and in that queue being bound to the amq.fanout exchange. This is indeed the case if the address is passed to the Drain example. However when passed to the Spout example, the queue is created but the binding is not established.

        Activity

        Rajith Attapattu added a comment - - edited

        This is not a regression, rather a bug that has been there for a while.
        This bug is due to the address resolution code not issuing a queue-bind after it creates the queue.
        The above address works as expected for consumers bcos to the registerConsumer method in AMQSession.java invokes the bindQueue method for both addressing and binding URL based destinations, therefore compensating for the above mistake.

        Rajith Attapattu added a comment -

        Fixed with a test case.


          People

          • Assignee:
            Rajith Attapattu
            Reporter:
            Gordon Sim
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development