Uploaded image for project: 'Qpid'
  1. Qpid
  2. QPID-3090

JMX ObjectName name may not match the underlying managed object

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 0.5, 0.6, 0.7, 0.8
    • Fix Version/s: 0.9
    • Component/s: Broker-J
    • Labels:
      None

      Description

      Because certain characters cannot be contained in an unquoted JMX ObjectName, the broker is currently remapping these characters (in some but not all cases) to different values to avoid trying to create an MBean with an illegal ObjectName. However, this can lead to situations where the broker considered an entity (eg a queue) to have one name, but users consider it to have another because that is what is displayed as the name of its MBean.

      This disconnect in naming is the cause of various issues, such as QPID-2486 and QPID-3094

        Issue Links

          Activity

          gemmellr Robbie Gemmell added a comment -

          Andrew can you review please? Thanks.

          andrew.kennedy Andrew Kennedy added a comment -

          Review OK


            People

            • Assignee:
              andrew.kennedy Andrew Kennedy
              Reporter:
              gemmellr Robbie Gemmell
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development