Qpid
  1. Qpid
  2. QPID-297

Maven build broken by exclusions on JUnit

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None

      Description

      This seems to be due to the exclusion of junit (3.7.1) as an incorrect depency of commons-lang:

      <dependency>
      <groupId>commons-lang</groupId>
      <artifactId>commons-lang</artifactId>
      <version>2.1</version>

      <exclusions>
      <exclusion>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      </exclusion>
      </exclusions>
      </dependency>

      Accoring to the article below, the exclusion from common-lang should not affect anything else. So the seperate declaration for junit 3.8.1 should not be wiped out by this. Removing the exclusion gets my build working though.

      http://maven.apache.org/guides/introduction/introduction-to-optional-and-excludes-dependencies.html

      Looks like a maven bug, can I suggest putting exclusions in the assembly descriptors instead?

      1. Qpid-297.diff
        8 kB
        Rupert Smith

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Rupert Smith
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development