Qpid
  1. Qpid
  2. QPID-2558

client connection.open to a non-broker on qpid 0.6 windows segfaults with: access violation

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.6
    • Fix Version/s: 0.7
    • Component/s: C++ Client
    • Environment:

      Microsoft Visual C++ Compiler, Windows Vista

      Description

      In windows environment, visual studio compiler, make a client like:

      Connection c;
      try

      { // there is no broker running at 10.10.5.51 so an exception should be thrown c.open("10.10.5.51",5672,"my_user","my_password"); }

      catch (...)

      { std::cout << "error" << std::endl; }

      on qpid 0.5 an exception is thrown and catched. ALL OK HERE
      on qpid 0.6 the program segfaults with the message:
      "Unhandled exception at 0x692eccb9 in testqpid06.exe: 0xC0000005: Access violation reading location 0x00000000."
      This error is thrown just after executing the "c.open" line.
      On Linux all is OK, the problem is only on Windows.

        Activity

        Steve Huston added a comment -

        This was fixed while adding SSL support; please try with the subversion development stream code.


          People

          • Assignee:
            Unassigned
            Reporter:
            Nicolae Claudius
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 336h
              336h
              Remaining:
              Remaining Estimate - 336h
              336h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development