Qpid
  1. Qpid
  2. QPID-2520

Broken POM generation on Windows

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.6
    • Fix Version/s: 0.7
    • Component/s: Build Tools, Python Tools
    • Labels:
      None

      Description

      The genpom script doesn't work on Windows. Calling "ant pom" gives the following stacktrace :

      pom:
           [java] Traceback (most recent call last):
           [java]   File "C:\dev\apache\qpid\java/genpom", line 95, in <module>
           [java]     pom = search(expanded_path, "%s.pom" % base)
           [java]   File "C:\dev\apache\qpid\java/genpom", line 83, in search
           [java]     return mllib.xml_parse(f)
           [java]   File "C:\dev\apache\qpid\python\mllib\__init__.py", line 79, in xml_parse
           [java]     p.parse(source)
           [java]   File "C:\dev\apache\qpid\java\lib\jython-2.5.0.jar\Lib\xml\sax\drivers2\drv_javasax.py", line 141, in parse
           [java]     at java.io.FileInputStream.open(Native Method)
           [java]     at java.io.FileInputStream.<init>(FileInputStream.java:106)
           [java]     at java.io.FileInputStream.<init>(FileInputStream.java:66)
           [java]     at sun.net.www.protocol.file.FileURLConnection.connect(FileURLConnection.java:70)
           [java]     at sun.net.www.protocol.file.FileURLConnection.getInputStream(FileURLConnection.java:161)
           [java]     at com.sun.org.apache.xerces.internal.impl.XMLEntityManager.setupCurrentEntity(XMLEntityManager.java:653)
           [java]     at com.sun.org.apache.xerces.internal.impl.XMLVersionDetector.determineDocVersion(XMLVersionDetector.java:186)
           [java]     at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:772)
           [java]     at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
           [java]     at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:119)
           [java]     at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
           [java]     at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
           [java]     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           [java]     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
           [java]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
           [java]     at java.lang.reflect.Method.invoke(Method.java:597)
           [java]
           [java] java.io.FileNotFoundException: java.io.FileNotFoundException: C:\dev\apache\qpid\java\common\dev\apache\qpid\java\lib\poms\slf4j-api-1.4.0.pom (Le chemin d'accès spécifié est introuvable)
      

      It works fine on Linux

      1. genpom.patch
        0.3 kB
        Emmanuel Bourg

        Activity

        Emmanuel Bourg added a comment -

        This is caused by a wrong path separator in the genpom script that restricts it to POSIX platforms. The fix is trivial.

        Robbie Gemmell added a comment -

        Patch applied


          People

          • Assignee:
            Robbie Gemmell
            Reporter:
            Emmanuel Bourg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development