Qpid
  1. Qpid
  2. QPID-2251

Provide portable signal mechanism for the C++ QMF agent API

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.7
    • Labels:
      None
    • Environment:

      Windows XP SP3, VC++ 9.0
      RHEL, Fedora

      Description

      Need a portable signaling mechanism in the QMF agent API for Windows and Posix platforms that encapsulates or hides socket and FD implementations

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          52d 6h 3m 1 Ted Ross 29/Jan/10 22:08
          Resolved Resolved Closed Closed
          1276d 20h 56m 1 Justin Ross 29/Jul/13 20:05
          Justin Ross made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Steve Huston added a comment -

          I think the changes Ted added (if I understand them correctly) make this a moot point... Ted?

          Pete MacKinnon added a comment -

          Should/could we wrap the type returned from getSignalFd()? Private posix impl on the wrapper returns int, private windows impl returns SOCKET.

          \Pete

          Ted Ross made changes -
          Fix Version/s 0.7 [ 12314455 ]
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          Ted Ross added a comment -

          I've left the other issue (1982) unresolved for now because there is one more API that needs this same fix.

          -Ted

          Steve Huston added a comment -

          This is a duplicate of QPID-1982

          Steve Huston made changes -
          Link This issue duplicates QPID-1982 [ QPID-1982 ]
          Ted Ross made changes -
          Assignee Ted Ross [ tedross ]
          Pete MacKinnon made changes -
          Field Original Value New Value
          Summary Provide portable file descriptor for the C++ QMF agent API Provide portable signal mechanism for the C++ QMF agent API
          Pete MacKinnon created issue -

            People

            • Assignee:
              Ted Ross
              Reporter:
              Pete MacKinnon
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development