Qpid Proton
  1. Qpid Proton
  2. PROTON-369

Ruby: Message class does not have a properties property

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.5
    • Component/s: None
    • Labels:
      None

      Description

      The Qpid::Proton::Message class should have a properties field that allows accessing and setting properties.

        Activity

        ASF subversion and git services added a comment -

        Commit 1509429 from Darryl L. Pierce in branch 'proton/trunk'
        [ https://svn.apache.org/r1509429 ]

        PROTON-369: Add the properties= method to Ruby Message.

        Also fixed a few small bugs caused by using the clone method on assigned
        values to properties, instructions and annotations.

        ASF subversion and git services added a comment -

        Commit 1508991 from Darryl L. Pierce in branch 'proton/trunk'
        [ https://svn.apache.org/r1508991 ]

        PROTON-369: Ruby Message.clear clears out properties

        Previously it was not clearing out the set of properties.

        ASF subversion and git services added a comment -

        Commit 1508619 from Darryl L. Pierce in branch 'proton/trunk'
        [ https://svn.apache.org/r1508619 ]

        PROTON-369: Add properties field to Qpid:Proton::Message

        Provides Rspec tests as well as updates the send and recv examples to
        use properties.


          People

          • Assignee:
            Darryl L. Pierce
            Reporter:
            Darryl L. Pierce
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development