Uploaded image for project: 'Qpid Proton'
  1. Qpid Proton
  2. PROTON-209

Update README file(s) to more specific about required versions of tools

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: proton-0.3
    • Fix Version/s: proton-c-0.18.0
    • Component/s: proton-c
    • Labels:

      Description

      We should be more explicit about which version of the following tools are required by Proton, either in the top level README or in READMEs in the relevant sub-folders:

      • Python (see PROTON-199).
      • Swig
      • cmake? (the required version is specified in the CMakeLists.txt files but maybe it would be polite to mention in the README too).
      • Maven? (or maybe we can omit this for same reasons as cmake version)
      • possibly others, e.g. openssl, gcc, epydoc, Perl, Ruby etc.

        Attachments

          Activity

            People

            • Assignee:
              jross Justin Ross
              Reporter:
              philharveyonline Phil Harvey
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: