Pluto
  1. Pluto
  2. PLUTO-565

Resource config not found under /WEB-INF/

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.0.1
    • Component/s: None
    • Labels:
      None

      Description

      It seems that the file "pluto-portal-driver-config.xml" doesn't get deployed to the portal WEB-INF directory.

      Pluto hangs because the file cannot be found in the context but it says almost nothing about what file is not found. This path is hardcoded in ResourceConfigReader.class

      I proposed to move the file from
      ./pluto-portal/src/main/resources/pluto-portal-driver-config.xml

      to

      WEB-INF directory or update build path in the pluto portal proyect.

      Also I will atach a patch to handle this situation.

        Activity

        Gonzalo Aguilar added a comment -

        This makes pluto handle broken resources better.

        Ate Douma added a comment -

        I cannot reproduce this and pluto-portal-driver-config.xml is added as WEB-INF resource just fine.
        My guess is you might have a custom build/configuration setup incorrectly.
        I suggest discussing this (and likewise issues) first on the pluto-dev list before creating an JIRA issue for it.

        Gonzalo Aguilar added a comment -

        Sorry I tried. I subscribed and wrote several times but the e-mails never arrived. But I receive all the e-mails from others in the list.

        I'm using eclipse and m2eclipse plugin. I tried several ways, several times and never got deployed on /WEB-INF/

        It's like this because this file is in resources. And they go always to the class directory of the jar file.

        I don't know if this is eclipse exclusive but it should work well even under this IDE.

        Tell me if I can do more on this issue. Anyway, I think the patch is right because it's only explicative.

        OFFTOPIC: Is there any way to discuss issues more dynamically other than the list?

        Ate Douma added a comment -

        Subscribing to the pluto-dev list as described on http://portals.apache.org/pluto/mail-lists.html definitely should work.
        Make sure to use the correct email account (and sender email address) where you expect the emails to be delivered and possibly check your spam filter...

        About the m2eclipse problem:
        The pluto-portal-driver-config.xml is merged into the war through the war-plugin itself because it needs to be filtered first (injecting the portal.version value).
        That might be doable differently too like with an additional build/resources configuration but that still means the m2eclipse plugin might not "see" it.
        The m2eclipse plugin is great (I use it myself), but still too limited IMO to deal with more customized/complex build configuration, so deployment I always still do through maven itself. (either through Eclipse or command line).

        OFFTOPIC: we (ASF) prefer using the mailing lists because that ensures everyone can see, chime in and learn from the shared/archived information.


          People

          • Assignee:
            Unassigned
            Reporter:
            Gonzalo Aguilar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development