Pluto
  1. Pluto
  2. PLUTO-522

pluto looks up wrong context when publish an event in response to an event

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.0
    • Component/s: portal driver
    • Labels:
      None

      Description

      I am experiencing a problem where I have two portals specified in the same war file.

      When portal b correctly receives an event from portal a, and then in response also tries to publish an event (setEvent), the pluto driver, when running EventProviderImpl#isDeclaredAsPublishingEvent while looking up the registered publish event names, looks up the portlet context of portlet a (instead of b, as b is the portlet publishing the event), and so does not find the matching publish name for the event.

      The example project can be found shortly on WICKET-1620.

        Activity

        Ate Douma added a comment -

        I just wrote a quick and dirty set of pingpong portlets testing this issue using multiple portlet apps but cannot reproduce anymore.
        Assuming this was an actual bug before, I'm now resolving it as fixed.


          People

          • Assignee:
            Unassigned
            Reporter:
            Antony Stubbs
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development