Pluto
  1. Pluto
  2. PLUTO-495

Eclipse autobuilld/compile/debug project

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.0.0
    • Component/s: build system
    • Labels:
      None
    • Environment:
      Ubuntu/Eclipse Java 1.5 x86

      Description

      Hello all!

      I wanted to checkout the project and contribute to it with some fixes and updates. But I found maven difficult to use/maintain and does not add anything to pure developement for beginners. This is only my opinion...

      So I decided to create a project overlayed into the main maven project so anyone can develop/debug with minimal effort with Eclipse. I'm trying not to break anything inside the tree so you can use the project without modifications.

      Maybe someone will want to use this overlay. The problem is that I don't know the right way to contribute with this. Should I do a patch? Do you think it's useful?

      Do you want me to prepare this for common use?

      Anyway, if you don't like it or don't want it, I will try to submit some patches to the project to try address several issues:
      1.- Functional bugs/improvements to the version 2.0 (trunk)
      2.- Configuration improvement (mostly logging and exception handling) to let developers what's going on in initialization.
      More on this later.

      Now what I'm doing is to track down whole initialization to check everything runs ok and learning how everything works...

      Thank you very much!
      Best regards,

        Issue Links

          Activity

          Gonzalo Aguilar created issue -
          Craig Doremus added a comment -

          We have not been keeping any of the configuration files for Eclipse (or any other IDE) in our source code repository. The m2eclipse plugin has improved greatly lately and should be used instead of manually updating the Java build path. Just make sure you configure the plugin to enable nested modules.

          We would greatly appreciate any help from the Pluto community. Find an issue is Jira you would like to work on and attach your patch file to the issue. If you use a Subversion plugin (I used Subclipse), creating a patch file is easy. If you don't have any preferences, I'd suggest PLUTO-443, which is to add a resource serving test to the JSR-286 testsuite.

          Gonzalo Aguilar added a comment -

          Ok I will work on this issue if I find my way to the code soon.

          Tnx

          Gonzalo Aguilar made changes -
          Field Original Value New Value
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Gonzalo Aguilar added a comment -

          Hi again, I'm ready to start.

          Just want to know if there are any guides to setup debug on eclipse 3.4 with Maven activated.
          Also I'm using the WTP tomcat plugin...

          Do you know how to prepare debug environment?

          Craig Doremus added a comment -

          Debugging instructions can be found on the Pluto Wiki here: http://wiki.apache.org/portals/Pluto/RemoteDebuggingWithPluto

          Gonzalo Aguilar added a comment -

          Yep, I saw this...

          But this does not support WTP server plugin, nor online debugging.

          I think I found the way to configure, build and debug the project with the m2eclipse + maven + WTP server tools inside the eclipse environment without using remote debugging.

          Seems to be really compact.

          I thought to write a HOWTO, if you want I can send it to you. Or post anywhere...

          Gonzalo Aguilar made changes -
          Link This issue blocks PLUTO-500 [ PLUTO-500 ]
          Gonzalo Aguilar added a comment -

          Linked to this because relevant.

          Tutorial submited in this Issue

          Mark Thomas made changes -
          Workflow jira [ 12437169 ] Default workflow, editable Closed status [ 12565323 ]
          Mark Thomas made changes -
          Workflow Default workflow, editable Closed status [ 12565323 ] jira [ 12586046 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Gonzalo Aguilar
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 336h
                336h
                Remaining:
                Remaining Estimate - 336h
                336h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development