Pluto
  1. Pluto
  2. PLUTO-452

Assembler ant task fails on WAR with no manifest

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.4, 1.2.0
    • Fix Version/s: 1.2.0, 1.1.5, 2.0.0
    • Component/s: deployer
    • Labels:
      None

      Description

      Running the assembler ant task on a WAR or EAR with no manifest results in a NullPointerException:

      Caused by: /Users/edalquist/java/workspace_33/uPortal_pluto/uportal-ear/build.xml:59: The following error occurred while executing this line:
      /Users/edalquist/java/workspace_33/uPortal_pluto/uportal-ear/build.xml:77: java.lang.NullPointerException: man
      at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:539)
      at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:384)
      at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:107)
      at org.apache.tools.ant.Task.perform(Task.java:364)
      at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:64)
      at net.sf.antcontrib.logic.ForEach.executeSequential(ForEach.java:178)
      at net.sf.antcontrib.logic.ForEach.execute(ForEach.java:254)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
      at org.apache.tools.ant.Task.perform(Task.java:364)
      at org.apache.tools.ant.Target.execute(Target.java:341)
      at org.apache.tools.ant.Target.performTasks(Target.java:369)
      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
      at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:37)
      at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
      at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:382)
      ... 32 more
      Caused by: /Users/edalquist/java/workspace_33/uPortal_pluto/uportal-ear/build.xml:77: java.lang.NullPointerException: man
      at org.apache.tools.ant.Task.perform(Task.java:373)
      at org.apache.tools.ant.Target.execute(Target.java:341)
      at org.apache.tools.ant.Target.performTasks(Target.java:369)
      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
      at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:37)
      at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
      at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:382)
      ... 45 more
      Caused by: java.lang.NullPointerException: man
      at java.util.jar.JarOutputStream.<init>(JarOutputStream.java:43)
      at org.apache.pluto.util.assemble.war.WarAssembler.assembleWar(WarAssembler.java:67)
      at org.apache.pluto.util.assemble.war.WarAssembler.assembleInternal(WarAssembler.java:53)
      at org.apache.pluto.util.assemble.AbstractArchiveAssembler.assemble(AbstractArchiveAssembler.java:87)
      at org.apache.pluto.ant.AssembleTask.execute(AssembleTask.java:222)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
      at org.apache.tools.ant.Task.perform(Task.java:364)
      ... 51 more

        Activity

        Elliot Metsger added a comment -

        Merged to 1.1-286-trunk-merge 607459

        Elliot Metsger added a comment -

        Merged to trunk 607456.

        Elliot Metsger added a comment -

        Patch, with test committed on 1.1.x 607455.

        Elliot Metsger added a comment -

        updated fix/affects

        Eric Dalquist added a comment -

        Fix that only tries to use the manifiest from the archive being assembled if it exists.


          People

          • Assignee:
            Elliot Metsger
            Reporter:
            Eric Dalquist
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development