Pluto
  1. Pluto
  2. PLUTO-370

Cannot build 1.1.3 GA release from source

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.3
    • Fix Version/s: 1.1.4
    • Component/s: build system
    • Labels:
      None
    • Environment:
      openSUSE 10.1, Sun JDK 1.5.0_08

      Description

      I downloaded the source distribution for the newly released version from the following URL:

      http://apache.oc1.mirrors.redwire.net/portals/pluto/SOURCES/v1.1.3/pluto-1.1.3-src.zip

      When I tried to build the distribution using the command 'mvn install', I received the following stack trace:

      bgould@bgould-laptop:~/Desktop/pluto-1.1.3> mvn install
      [INFO] Scanning for projects...
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Error building POM (may not be this project's POM).

      Project ID: unknown

      Reason: Could not find the model file '/home/bgould/Desktop/pluto-1.1.3/pluto-resources/pom.xml'.

      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.reactor.MavenExecutionException: Could not find the model file '/home/bgould/Desktop/pluto-1.1.3/pluto-resources/pom.xml'.
      at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:378)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:290)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:125)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:272)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:615)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430) at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.project.ProjectBuildingException: Could not find the model file '/home/bgould/Desktop/pluto-1.1.3/pluto-resources/pom.xml'.
      at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1384)
      at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.java:477)
      at org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:200)
      at org.apache.maven.DefaultMaven.getProject(DefaultMaven.java:537)
      at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:467)
      at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:511)
      at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:364)
      ... 11 more
      Caused by: java.io.FileNotFoundException: /home/bgould/Desktop/pluto-1.1.3/pluto-resources/pom.xml (No such file or directory)
      at java.io.FileInputStream.open(Native Method)
      at java.io.FileInputStream.<init>(FileInputStream.java:135)
      at java.io.FileReader.<init>(FileReader.java:78)
      at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1379)
      ... 17 more
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: < 1 second
      [INFO] Finished at: Tue May 22 00:19:01 EDT 2007
      [INFO] Final Memory: 2M/7M
      [INFO] ------------------------------------------------------------------------
      bgould@bgould-laptop:~/Desktop/pluto-1.1.3>

      If I comment out the pluto-resources modules in the pom.xml of the base directory, the distribution builds successfully (as far as I can tell).

        Activity

        Elliot Metsger added a comment -

        Hi Benjamin,

        Thanks for this report. I'll fix this in the branch and update the website letting people know.

        Elliot Metsger added a comment -

        the extraneous module has been fixed in the branch. I'm not going to bother to update the website, as 1.1.4 will be out soon enough, correcting this problem.


          People

          • Assignee:
            Elliot Metsger
            Reporter:
            Benjamin Gould
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development