Uploaded image for project: 'Pivot'
  1. Pivot
  2. PIVOT-998

Update "trunk" to require Java 8

    XMLWordPrintableJSON

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.1.0
    • Component/s: all
    • Labels:
      None
    • Environment:
      All

      Description

      Since "trunk" is unreleased as of yet, and Java 8 is quite mature, and Java 9 is due out later this year, and there are features of Java 8 (such as lambdas) that we would like to take advantage of for new development, it seems wise to require Java 8 going forward for the "trunk", while leaving the 2.0.x maintenance branch at Java 6. Previously we had upgraded to requiring Java 7 for "trunk", but that version is stabilized and no longer being updated...

        Attachments

          Activity

            People

            • Assignee:
              rwhitcomb Roger Lee Whitcomb
              Reporter:
              rwhitcomb Roger Lee Whitcomb
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: