Uploaded image for project: 'Pivot'
  1. Pivot
  2. PIVOT-427

Rename Direction enum to FocusTraversalDirection

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5
    • Component/s: wtk
    • Labels:

      Description

      It is somewhat arbitrary to define direction as "forward" and "backward", and this enum is used almost exclusively for focus traversal. The only other place it is used is in the delete() method of TextArea and TextInput, which uses Direction.BACKWARD to represent "backspace". This makes some sense, but Direction.FORWARD doesn't really correspond to "delete". This method should instead take a boolean "backspace" argument that would be used to distinguish between backspace and delete. Then the only use of the Direction enum would truly be focus traversal, and the name "FocusTraversalDirection" is more appropriate.

        Attachments

          Activity

            People

            • Assignee:
              gbrown Gregory K. Brown
              Reporter:
              gbrown Gregory K. Brown

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment