Uploaded image for project: 'Pig'
  1. Pig
  2. PIG-4909

PigStorage incompatible with commons-cli-1.3

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.16.0
    • Component/s: impl
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Pig uses commons-cli-1.2.jar but when user overwrite the classpath with commons-cli-1.3.jar, job failed with

      Caused by: java.lang.IllegalArgumentException: Illegal option name ' '
      at org.apache.commons.cli.OptionValidator.validateOption(OptionValidator.java:60)
      

        Attachments

        1. pig-4909-v01-notest.patch
          0.9 kB
          Koji Noguchi

          Activity

            People

            • Assignee:
              knoguchi Koji Noguchi
              Reporter:
              knoguchi Koji Noguchi
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: