Pig
  1. Pig
  2. PIG-2310

bin/pig fail when both pig-0.9.1.jar and pig.jar are in PIG_HOME

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.9.1, 0.10.0
    • Fix Version/s: 0.9.1, 0.10.0
    • Component/s: impl
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    1. PIG-2310-2.patch
      1 kB
      Daniel Dai
    2. PIG-2310-1.patch
      0.9 kB
      Daniel Dai

      Activity

      Daniel Dai added a comment -

      Patch committed to both trunk and 0.9 branch.

      Alan Gates added a comment -

      +1, looks good, and works both before and after "ant jar".

      Daniel Dai added a comment -

      The error is because of the CDPATH setting on the target machine. Once CDPATH is set, cd will echo the path.

      Note this is issue is there for a long time and is not related to any recent change.

      Alan Gates added a comment -

      There's more to this than just the jars being present. When I tried the patch in the directory /homes/hortonal/src/pig/branches/0.9/2310/branch-0.9 I got:

       bin/pig -x local
      bin/pig: line 68: [: ./bin: binary operator expected
      bin/pig: line 262: [: ./bin: binary operator expected
      Exception in thread "main" java.lang.NoClassDefFoundError: /home/hortonal/src/pig/branches/0/9/2310/branch-0/9/bin////logs
      Caused by: java.lang.ClassNotFoundException: .home.hortonal.src.pig.branches.0.9.2310.branch-0.9.bin....logs
              at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
              at java.security.AccessController.doPrivileged(Native Method)
              at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
              at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
              at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:276)
              at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
              at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
      

      Notice the way it's mangling my path by replacing dots with slashes.

      Also, I get a similar error when I try to run this in a directory without dots.


        People

        • Assignee:
          Daniel Dai
          Reporter:
          Daniel Dai
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development