Uploaded image for project: 'Phoenix'
  1. Phoenix
  2. PHOENIX-6326

Phoenix doesn't work with Java version 11.0.9.1 , due to Jetty problem

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 5.1.0, 4.16.0
    • Fix Version/s: 5.1.0
    • Component/s: core
    • Labels:
    • Release Note:
      Hide
      There is bug in the Jetty version used by HBase 2.3 and earlier, that causes incompatilbity with Java releases that have a four number version string like "11.0.9.1"
      As Phoenix builds on top of HBase, Phoenix is also incompatible with these releases, when built with an hbase.profile older than 2.4.
      Show
      There is bug in the Jetty version used by HBase 2.3 and earlier, that causes incompatilbity with Java releases that have a four number version string like "11.0.9.1" As Phoenix builds on top of HBase, Phoenix is also incompatible with these releases, when built with an hbase.profile older than 2.4.

      Description

      Looks like we need to upgrade either Hadoop or Jetty dependency.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                stoty Istvan Toth
                Reporter:
                stoty Istvan Toth
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: