Uploaded image for project: 'Phoenix'
  1. Phoenix
  2. PHOENIX-3346

Hive PhoenixStorageHandler doesn't work well with column mapping

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.10.0
    • Labels:

      Description

      If column mapping is used during table creation, the hive table becomes unusable and throws UnknownColumn exception.
      There are several issues in the current implementation:
      1. During table creation mapping doesn't applies to primary keys
      2. During select query building no mapping happen
      3. PhoenixRow should have backward mapping from phoenix column names to hive names.

      1. PHOENIX-3346-1.patch
        62 kB
        Sergey Soldatov

        Issue Links

          Activity

          sergey.soldatov Sergey Soldatov added a comment -

          The patch includes:
          1. proper column mapping for both rowkeys and regular columns, fully supported in both MR and Tez jobs
          2. Fix for MR/Tez jobs when job fails if no hbase-site.xml in the app classpath. No need for it anymore and all connection parameters comes from table properties
          3. Added tez support to IT tests. Now we have a single set of tests that executed for both MR and Tez.
          4. Added integration tests that verify that data written in Hive is accessible not only on Phoenix side, but from Hive as well.

          Notes:
          1. Hive always using low case names for columns. Without additional mapping, the phoenix table will have low case names as well.
          2. New tests involve running quite a lot of yarn jobs (for each insert into Hive table, as well as for running Hive queries), so the execution is quite slow and may be unstable due resource limitation.

          jamestaylor James Taylor added a comment - - edited

          This is fantastic, Sergey Soldatov! Who would be the best person to review this? Maybe Enis Soztutar or Josh Elser? Also, would you mind filing a separate JIRA to update the docs?

          elserj Josh Elser added a comment -

          Yeah, I can take a look. Thanks for the ping, James.

          Nick Dimiduk did some work (back in the day) with the HBaseStorageHandler, so he might be good as well if he has the cycles

          elserj Josh Elser added a comment -

          3. Added tez support to IT tests. Now we have a single set of tests that executed for both MR and Tez.

          This is pretty awesome!

          I tried running the new tests mvn clean verify -Dit.test="Hive*IT" and they are not passing. The JVM appears to be crashing:

          Caused by: java.lang.RuntimeException: The forked VM terminated without properly saying goodbye. VM crash or System.exit called?
          Command was /bin/sh -c cd /Users/jelser/projects/phoenix.git/phoenix-hive && /Library/Java/JavaVirtualMachines/jdk1.8.0_45.jdk/Contents/Home/jre/bin/java -enableassertions -Xmx2000m -XX:MaxPermSize=256m -Djava.security.egd=file:/dev/./urandom '-Djava.library.path=${hadoop.library.path}:/Users/jelser/Library/Java/Extensions:/Library/Java/Extensions:/Network/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java:.' -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=./target/ -jar /Users/jelser/projects/phoenix.git/phoenix-hive/target/surefire/surefirebooter1033061363721012190.jar /Users/jelser/projects/phoenix.git/phoenix-hive/target/surefire/surefire4036485710539380932tmp /Users/jelser/projects/phoenix.git/phoenix-hive/target/surefire/surefire_14462149970274711357tmp
                  at org.apache.maven.plugin.surefire.booterclient.ForkStarter.fork(ForkStarter.java:590)
                  at org.apache.maven.plugin.surefire.booterclient.ForkStarter.fork(ForkStarter.java:460)
                  at org.apache.maven.plugin.surefire.booterclient.ForkStarter.access$400(ForkStarter.java:110)
                  at org.apache.maven.plugin.surefire.booterclient.ForkStarter$2.call(ForkStarter.java:379)
                  at org.apache.maven.plugin.surefire.booterclient.ForkStarter$2.call(ForkStarter.java:356)
                  at java.util.concurrent.FutureTask.run(FutureTask.java:266)
                  at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
                  at java.lang.Thread.run(Thread.java:745)
          

          +1 from me regardless. We can deal with test-failures later – it might just be my machine.

          jamestaylor James Taylor added a comment -

          Would you have a few cycles to get this committed, Josh Elser? Should we kick off a test run to make sure the Hive-related tests pass?

          jamestaylor James Taylor added a comment -

          Sergey Soldatov - please commit this.

          elserj Josh Elser added a comment - - edited

          Would you have a few cycles to get this committed, Josh Elser? Should we kick off a test run to make sure the Hive-related tests pass?

          I'm sorry for ignoring ya, James, rough week. Seeing what HadoopQA has to say about those tests would be good...

          kicked off a precommit (not sure why it didn't run the first time) https://builds.apache.org/view/PreCommit%20Builds/job/PreCommit-PHOENIX-Build/773/console

          sergey.soldatov Sergey Soldatov added a comment -

          let me do it. I'm in the process of reviewing/combining all fixes related to storage handler, so if everything is smoothly it will be a set of patches. It's just a bit slow to check that nothing is broken. Will try to get it into by Monday.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12847427/PHOENIX-3346-1.patch
          against master branch at commit c3b16cef5de15df059b5c979a1b54110e5b0ca00.
          ATTACHMENT ID: 12847427

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 4 new or modified tests.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 javadoc. The javadoc tool appears to have generated 43 warning messages.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 lineLengths. The patch introduces the following lines longer than 100:
          + "VALUES (10, \"foodesc\", \"2013-01-05 01:01:01\", 200,2.0,-1);" + HiveTestUtil.CRLF);
          + sb.append("INSERT INTO TABLE phoenix_MultiKey VALUES (10, \"part2\",\"foodesc\",200,2.0,-1);" +
          + * Test that hive is able to access Phoenix data during MR job (creating two tables and perform join on it)
          + sb.append("INSERT INTO TABLE joinTable1 VALUES (5, \"part2\",\"foodesc\",200,2.0,-1);" + HiveTestUtil.CRLF);
          + sb.append("INSERT INTO TABLE joinTable1 VALUES (10, \"part2\",\"foodesc\",200,2.0,-1);" + HiveTestUtil.CRLF);
          + sb.append("INSERT INTO TABLE joinTable2 VALUES (5, \"part2\",\"foodesc\",200,2.0,-1);" + HiveTestUtil.CRLF);
          + sb.append("INSERT INTO TABLE joinTable2 VALUES (10, \"part2\",\"foodesc\",200,2.0,-1);" + HiveTestUtil.CRLF);
          + * Test that hive is able to access Phoenix data during MR job (creating two tables and perform join on it)
          + sb.append("INSERT INTO TABLE joinTable3 VALUES (5, \"part1\",\"foodesc\",200,2.0,-1);" + HiveTestUtil.CRLF);
          + sb.append("INSERT INTO TABLE joinTable3 VALUES (10, \"part1\",\"foodesc\",200,2.0,-1);" + HiveTestUtil.CRLF);

          -1 core tests. The patch failed these unit tests:

          Test results: https://builds.apache.org/job/PreCommit-PHOENIX-Build/773//testReport/
          Javadoc warnings: https://builds.apache.org/job/PreCommit-PHOENIX-Build/773//artifact/patchprocess/patchJavadocWarnings.txt
          Console output: https://builds.apache.org/job/PreCommit-PHOENIX-Build/773//console

          This message is automatically generated.

          jamestaylor James Taylor added a comment -

          Sergey Soldatov - would it be possible to get this committed in the next few days so we can include it in 4.10?

          sergey.soldatov Sergey Soldatov added a comment -
          sergey.soldatov Sergey Soldatov added a comment -

          Committed to master and 4.x branches. Josh Elser thank you for the review James Taylor thank you for your patience.

          samarthjain Samarth Jain added a comment -

          Sergey Soldatov - looks like the checkin broke tests in the hive module.

          https://builds.apache.org/job/Phoenix-4.x-HBase-0.98/1461/console

          Can you please take a look?

          hudson Hudson added a comment -

          FAILURE: Integrated in Jenkins build Phoenix-master #1572 (See https://builds.apache.org/job/Phoenix-master/1572/)
          PHOENIX-3346 Hive PhoenixStorageHandler doesn't work well with column (ssa: rev 7201dd5e17096209d26ca3620054fc72665cf4fe)

          • (edit) phoenix-hive/src/main/java/org/apache/phoenix/hive/PhoenixSerializer.java
          • (add) phoenix-hive/src/main/java/org/apache/phoenix/hive/util/ColumnMappingUtils.java
          • (edit) phoenix-hive/src/it/java/org/apache/phoenix/hive/HiveTestUtil.java
          • (edit) phoenix-hive/src/main/java/org/apache/phoenix/hive/PhoenixStorageHandler.java
          • (add) phoenix-hive/src/it/java/org/apache/phoenix/hive/HiveTezIT.java
          • (edit) phoenix-hive/src/test/java/org/apache/phoenix/hive/query/PhoenixQueryBuilderTest.java
          • (edit) phoenix-hive/src/main/java/org/apache/phoenix/hive/PhoenixSerDe.java
          • (edit) phoenix-hive/src/main/java/org/apache/phoenix/hive/PhoenixMetaHook.java
          • (add) phoenix-hive/src/it/java/org/apache/phoenix/hive/HiveMapReduceIT.java
          • (edit) phoenix-hive/src/main/java/org/apache/phoenix/hive/util/PhoenixConnectionUtil.java
          • (edit) phoenix-hive/src/it/java/org/apache/phoenix/hive/HivePhoenixStoreIT.java
          • (edit) phoenix-hive/src/main/java/org/apache/phoenix/hive/mapreduce/PhoenixInputFormat.java
          • (edit) phoenix-hive/src/main/java/org/apache/phoenix/hive/mapreduce/PhoenixResultWritable.java
          • (add) phoenix-hive/src/it/java/org/apache/phoenix/hive/BaseHivePhoenixStoreIT.java
          • (edit) phoenix-hive/src/main/java/org/apache/phoenix/hive/query/PhoenixQueryBuilder.java
          • (edit) phoenix-hive/pom.xml
          • (edit) phoenix-hive/src/main/java/org/apache/phoenix/hive/mapreduce/PhoenixRecordReader.java
          sergey.soldatov Sergey Soldatov added a comment -

          Samarth Jain yep, just committed a missing fix for UT.

          samarthjain Samarth Jain added a comment -

          Sergey Soldatov - did you commit to all the branches? I see builds still failing for 4.x-HBase-1.1 ( https://builds.apache.org/job/Phoenix-4.x-HBase-1.1/353/ )

          sergey.soldatov Sergey Soldatov added a comment -

          Samarth Jain Well, I did, but had typo in the name branch, so it just went and created a new one. Should be fine now.

          hudson Hudson added a comment -

          FAILURE: Integrated in Jenkins build Phoenix-master #1574 (See https://builds.apache.org/job/Phoenix-master/1574/)
          Fixed UT for PHOENIX-3346 Hive PhoenixStorageHandler doesn't work well (ssa: rev 9ba564bbd972284554ceec18e34016ac458997b2)

          • (edit) phoenix-hive/src/test/java/org/apache/phoenix/hive/query/PhoenixQueryBuilderTest.java
          samarthjain Samarth Jain added a comment -

          Thank you, Sergey Soldatov. Sorry for being on your case. Just trying to get builds stabilized for our 4.10 release. It looks like the newly added hive tests are not completing. See this crawler report - https://builds.apache.org/job/PhoenixFindTestTimeout/538/console

          sergey.soldatov Sergey Soldatov added a comment -

          Samarth Jain yep, I saw. That's quite strange behavior - they are working just fine with surefire (when running from IDE or using maven test) and fails to run without any visible reason with failsafe plugin. I will temporary add them to ignore to get build stabilized and will dig into why it happen.

          samarthjain Samarth Jain added a comment -

          I am wondering if it is because the parent class, HivePhoenixStoreIT has an ignore tag at the class level. failsafe may not be liking it. Maybe just make HivePhoenixStoreIT an abstract class and remove the ignore tag?

          sergey.soldatov Sergey Soldatov added a comment - - edited

          tried that already when initially did split for MR/Tez But will check it again just in case. Tests start well and create HBase minicluster but not going further. Actually it seems that the problem is how failsafe and surefire run tests. Failsafe is using jar artifacts while surefire is using compiled classes. The rest is supposed to be the same. Since the hive jar built using assembly plugin there is a chance that some of META-INF stuff cause that problem. Just need some time to debug it.

          hudson Hudson added a comment -

          FAILURE: Integrated in Jenkins build Phoenix-master #1575 (See https://builds.apache.org/job/Phoenix-master/1575/)
          PHOENIX-3708 temporary disable tests introduced in PHOENIX-3346 (ssa: rev cf65fb27edf62666691500e3f7e7549c4b83240f)

          • (edit) phoenix-hive/src/it/java/org/apache/phoenix/hive/HiveMapReduceIT.java
          • (edit) phoenix-hive/src/it/java/org/apache/phoenix/hive/HiveTezIT.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Jenkins build Phoenix-master #1658 (See https://builds.apache.org/job/Phoenix-master/1658/)
          PHOENIX-3708 Tests introduced in PHOENIX-3346 doesn't work well with (ssa: rev 616cd057d3c7d587aafe278948f8cff84efc9d29)

          • (edit) phoenix-hive/src/it/java/org/apache/phoenix/hive/HiveMapReduceIT.java
          • (edit) phoenix-hive/src/it/java/org/apache/phoenix/hive/HiveTezIT.java
          • (edit) phoenix-hive/src/it/java/org/apache/phoenix/hive/HiveTestUtil.java
          • (edit) phoenix-hive/src/main/java/org/apache/phoenix/hive/query/PhoenixQueryBuilder.java
          • (edit) phoenix-hive/src/it/java/org/apache/phoenix/hive/BaseHivePhoenixStoreIT.java
          • (edit) phoenix-hive/pom.xml

            People

            • Assignee:
              sergey.soldatov Sergey Soldatov
              Reporter:
              sergey.soldatov Sergey Soldatov
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development