Uploaded image for project: 'PDFBox'
  1. PDFBox
  2. PDFBOX-894

Can`t open XREF as a stream. Latin Chars unreconized


    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.1
    • Fix Version/s: 1.3.1
    • Component/s: Parsing
    • Labels:
    • Environment:
      Windows XP


      Latin characters (e.g. á, é, í, õ, ç) just aren`t recognized in PDF, creating text files with strange characters like Œ, ? and ˆ instead of the right ones.

      I tryied to investigate through the PDFBox code what could have caused this, but with my limited knowledge on PDF formating, I couldn`t advance too much.

      There are 2 points which I`d like to comment:
      1 - The PDF has no XREF table, using Stream XREF(e.g. 3076/Type/XRef/W[1 3 1]>>stream) instead;
      2 - While encoding the byte stream (COSStream.getFilteredStream().doEncode()) the Filter encoding is FlateDecode (not sure if it`s a real issue, since in other PDFs I get this same encoding and it works fine).

      I`m not sure if there`s a problem with the pdf itself, since I can open it and see the Latin Characters with no trouble at Adobe and Foxit Readers.

      Attached is on of the PDFs that I`m talking about. The issue is seen from the 5th page on.


        1. PDFBOX894-TJMT_20101025_1.3.1.txt
          4 kB
          Andreas Lehmkühler
        2. TJMT_20101025.pdf
          3.44 MB
          Pedro Rodrigues



            • Assignee:
              lehmi Andreas Lehmkühler
              pvictorcr Pedro Rodrigues
            • Votes:
              0 Vote for this issue
              1 Start watching this issue


              • Created: