Uploaded image for project: 'PDFBox'
  1. PDFBox
  2. PDFBOX-3614

Directly use the BouncyCastleProvider rather than installing it

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.3
    • Fix Version/s: 2.0.6, 3.0.0 PDFBox
    • Component/s: None
    • Labels:
      None
    • Flags:
      Patch

      Description

      The BouncyCastleProvider is in installed in a static block and this makes it available to other code, when the usage can be contained to a single class inside of PDFBox by using the provider directly.

      Doing this also has the added advantage of not requiring additional security permissions when running code that is protected by a SecurityManager. Currently one needs to grant

      permission java.security.SecurityPermission "insertProvider"

      since the provider is being installed.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                lehmi Andreas Lehmkühler
                Reporter:
                jaymode Jay Modi
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: