PDFBox
  1. PDFBox
  2. PDFBOX-1249

PDF/A file has a preflight, .pdmodel.font exception. Validates with commercial viewers

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.0
    • Fix Version/s: 1.7.0
    • Component/s: PDModel, Preflight
    • Labels:
      None
    • Environment:
      LInux

      Description

      java.lang.NullPointerException
      at org.apache.pdfbox.pdmodel.font.PDType0Font.encode(PDType0Font.java:182)
      at org.apache.padaf.preflight.contentstream.ContentStreamWrapper.validText(ContentStreamWrapper.java:339)
      at org.apache.padaf.preflight.contentstream.ContentStreamWrapper.validStringArray(ContentStreamWrapper.java:280)
      at org.apache.padaf.preflight.contentstream.ContentStreamWrapper.validStringArray(ContentStreamWrapper.java:278)
      at org.apache.padaf.preflight.contentstream.ContentStreamWrapper.checkShowTextOperators(ContentStreamWrapper.java:207)
      at org.apache.padaf.preflight.contentstream.ContentStreamWrapper.processOperator(ContentStreamWrapper.java:180)
      at org.apache.pdfbox.util.PDFStreamEngine.processSubStream(PDFStreamEngine.java:274)
      at org.apache.pdfbox.util.PDFStreamEngine.processSubStream(PDFStreamEngine.java:251)
      at org.apache.pdfbox.util.PDFStreamEngine.processStream(PDFStreamEngine.java:225)
      at org.apache.padaf.preflight.contentstream.ContentStreamWrapper.validPageContentStream(ContentStreamWrapper.java:79)
      at org.apache.padaf.preflight.helpers.PagesValidationHelper.validateContent(PagesValidationHelper.java:196)
      at org.apache.padaf.preflight.helpers.PagesValidationHelper.validatePage(PagesValidationHelper.java:105)
      at org.apache.padaf.preflight.helpers.PagesValidationHelper.innerValidate(PagesValidationHelper.java:73)
      at org.apache.padaf.preflight.helpers.AbstractValidationHelper.validate(AbstractValidationHelper.java:91)
      at org.apache.padaf.preflight.AbstractValidator.runValidation(AbstractValidator.java:122)
      at org.apache.padaf.preflight.PdfA1bValidator.validate(PdfA1bValidator.java:97)
      at org.apache.padaf.preflight.Validator_A1b.validate(Validator_A1b.java:182)
      at org.apache.padaf.preflight.Validator_A1b.<init>(Validator_A1b.java:86)
      at org.apache.padaf.preflight.Validator_A1b.main(Validator_A1b.java:80)

      1. SeminarPDFA.pdf
        472 kB
        William Fausser

        Activity

        Andreas Lehmkühler made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        William Fausser added a comment -

        Hi Eric,

        Thanks, I was "much" out of date with pdfbox......got everything compiled and I can verify with you that the Null pointer exception was fixed
        a while back...thanks again.

        BR,
        Bill

        Eric Leleu made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 1.7.0 [ 12316940 ]
        Resolution Fixed [ 1 ]
        Eric Leleu added a comment -

        This NullPointerException may have been fixed by the PDFBOX-925.

        BR,
        Eric

        William Fausser added a comment - - edited

        Hi Eric,

        I'm not following with "Head revision".....could you point to an issue or tag number?

        BR,
        Bill

        Eric Leleu added a comment -

        Hi,

        I can't reproduce this Error with the HEAD revision.
        Could you confirm that point on your environment?

        BR,
        Eric

        Eric Leleu made changes -
        Assignee Eric Leleu [ leleueri ]
        William Fausser made changes -
        Field Original Value New Value
        Attachment SeminarPDFA.pdf [ 12517558 ]
        William Fausser created issue -

          People

          • Assignee:
            Eric Leleu
            Reporter:
            William Fausser
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development