Uploaded image for project: 'Parquet'
  1. Parquet
  2. PARQUET-2058

Parquet-tools is affected by multiple CVEs

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Blocker
    • Resolution: Unresolved
    • Affects Version/s: 1.10.0, 1.10.1, 1.11.1
    • Fix Version/s: None
    • Component/s: parquet-mr
    • Labels:
    • Flags:
      Important

      Description

      The parquet-tools library is affected by multiple CVEs.

       

      CVE-2018-10237 https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-10237 Unbounded memory allocation in Google Guava 11.0 through 24.x before 24.1.1 allows remote attackers to conduct denial of service attacks against servers that depend on this library and deserialize attacker-provided data, because the AtomicDoubleArray class (when serialized with Java serialization) and the CompoundOrdering class (when serialized with GWT serialization) perform eager allocation without appropriate checks on what a client has sent and whether the data size is reasonable.
      CVE-2020-8908 https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-8908 A temp directory creation vulnerability exists in all versions of Guava, allowing an attacker with access to the machine to potentially access data in a temporary directory created by the Guava API com.google.common.io.Files.createTempDir(). By default, on unix-like systems, the created directory is world-readable (readable by an attacker with access to the system). The method in question has been marked @Deprecated in versions 30.0 and later and should not be used. For Android developers, we recommend choosing a temporary directory API provided by Android, such as context.getCacheDir(). For other Java developers, we recommend migrating to the Java 7 API java.nio.file.Files.createTempDirectory() which explicitly configures permissions of 700, or configuring the Java runtime\'s java.io.tmpdir system property to point to a location whose permissions are appropriately configured.
      CVE-2019-17571 https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-17571 Included in Log4j 1.2 is a SocketServer class that is vulnerable to deserialization of untrusted data which can be exploited to remotely execute arbitrary code when combined with a deserialization gadget when listening to untrusted network traffic for log data. This affects Log4j versions up to 1.2 up to 1.2.17.
      CVE-2020-9488 https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-9488 Improper validation of certificate with host mismatch in Apache Log4j SMTP appender. This could allow an SMTPS connection to be intercepted by a man-in-the-middle attack which could leak any log messages sent through that appender.

       

       

      Is it possible to upgrade the POM files to reference the latest version of log4j and guava library?

       

      Thanks

      Tony

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              TonyLiu Tony Liu
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: