Uploaded image for project: 'ORC'
  1. ORC
  2. ORC-861

Bump CMake minimum requirement to 2.8.12

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.0
    • Fix Version/s: 1.7.0, 1.6.10
    • Component/s: C++
    • Labels:

      Description

      As of today, we are currently using CMake 3.21.0.

      $ cmake --version
      cmake version 3.21.0
      

      We are hitting this warning because our minimum requirement is 2.6.

      $ cmake ..
      CMake Deprecation Warning at CMakeLists.txt:13 (cmake_minimum_required):
        Compatibility with CMake < 2.8.12 will be removed from a future version of
        CMake.
      
        Update the VERSION argument <min> value or use a ...<max> suffix to tell
        CMake that the project does not need compatibility with older versions.
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dongjoon Dongjoon Hyun
                Reporter:
                dongjoon Dongjoon Hyun
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: