Uploaded image for project: 'OpenEJB'
  1. OpenEJB
  2. OPENEJB-1053

web.xml: unexpected element (uri:"http://java.sun.com/xml/ns/javaee", local:"taglib"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.1.3
    • Component/s: None
    • Labels:
      None
    • Environment:
      All

      Description

      When deploying a web application with an old deployment descriptor (Servlet 2.3), openejb fails while unmashalling.
      The Servlet specification clearly says:

      For backwards compatibility of applications written to the 2.2 version of the Web containers are also required to support the 2.2 version of the descriptor. For backward compatibility of applications written to the 2.3 version of the API,Web containers are also required to support the 2.3 version of the deployment descriptor. The 2.2 and 2.3 versions are deļ¬ned in the appendices.
      

        Attachments

        1. reproduce-1053.txt
          15 kB
          Jean-Louis MONTEIRO

          Activity

            People

            • Assignee:
              jlmonteiro Jean-Louis MONTEIRO
              Reporter:
              jlmonteiro Jean-Louis MONTEIRO
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: