Uploaded image for project: 'Oozie'
  1. Oozie
  2. OOZIE-3650

upgrade jackson to 2.6.7

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 5.3.0
    • None

    Description

      Oozie currently has a dependency on an old version of Jackson (2.6.5) - https://github.com/apache/oozie/blob/master/pom.xml#L119

      There are a number of CVEs open affecting this version.

      https://mvnrepository.com/artifact/com.fasterxml.jackson.core/jackson-databind/2.6.5

      Attachments

        1. OOZIE-3650-004.patch
          0.9 kB
          PJ Fanning
        2. OOZIE-3650-003.patch
          0.5 kB
          PJ Fanning

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            pj.fanning PJ Fanning
            pj.fanning PJ Fanning
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment