Uploaded image for project: 'Oozie'
  1. Oozie
  2. OOZIE-3599

Upgrade Jetty to 9.4.28

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 5.2.0
    • Fix Version/s: trunk
    • Component/s: None
    • Labels:
      None

      Description

      Jetty could be upgraded to the latest version, which is now 9.4.28.v20200408, though it has to be checked before if its feasible.

      In case we upgrade we have to be aware of wildcard certs with SAN as well and should change the code to use SslContextFactory.server instead of SsslContextFactory in org.apache.oozie.server.SSLServerConnectorFactory class.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              matijhs Mate Juhasz
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: