Uploaded image for project: 'Oozie'
  1. Oozie
  2. OOZIE-2178

fix javadoc to compile on JDK8

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.3.0
    • Component/s: None
    • Labels:
      None

      Description

      creating this JIRA from discussion on OOZIE-2177

      JDK8 enforce strict HTML4 checking on javadoc.
      when compiling oozie on JDK8, hit following javadoc error

      [ERROR] /Users/egashira/Projects/git/aoozie-cms/client/src/main/java/org/apache/oozie/cli/OozieCLI.java:205: error: self-closing element not allowed
      [ERROR] * <p/>

      the fix is to change self-closing element <p/>, <br/> to <p></p>, <br></br>

        Attachments

        1. OOZIE-2178.patch
          224 kB
          Robert Kanter
        2. OOZIE-2178.patch
          223 kB
          Robert Kanter

          Issue Links

            Activity

              People

              • Assignee:
                rkanter Robert Kanter
                Reporter:
                egashira Ryota Egashira
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: