Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-9512

Lead Profile URL not working properly in SFA

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Trunk, Release Branch 16.11
    • Fix Version/s: Upcoming Release
    • Component/s: marketing
    • Labels:
      None

      Description

      #Issue1
      Steps to reproduce:
      1. Go to sfa component https://demo-trunk.ofbiz.apache.org/sfa/control/main.
      2. Click on the Lead link in sub menu https://demo-trunk.ofbiz.apache.org/sfa/control/FindLeads.
      3. In "Find SFA Leads" section, click on "My Leads" button.
      4. Click on partyId link of any Lead https://demo-trunk-ofbiz.apache.org:8443/sfa/control/FindLeads?all=false.
      Profile page shows no information.

      #Issue2
      1. Navigate to SFA component https://demo-trunk.ofbiz.apache.org/sfa/control/main.
      2. Click on the Contacts link in sub menu https://demo-trunk.ofbiz.apache.org/sfa/control/FindContacts.
      3. In "Find SFA Contacts" section, click on "My Contacts" button.
      4. Click on partyId link of any Contact https://demo-trunk.ofbiz.apache.org/sfa/control/viewprofile?partyId=DemoCustomer.

      Profile page shows no information.

      #Issue 3
      1. Navigate to SFA component https://demo-trunk.ofbiz.apache.org/sfa/control/main.
      2. Click on the Lead link in sub menu https://demo-trunk.ofbiz.apache.org/sfa/control/FindLeads.
      3. In "Find SFA Leads" section, click on "My Leads" button.
      4. Click on partyId link of any Lead https://demo-trunk-ofbiz.apache.org:8443/sfa/control/FindLeads?all=false.
      5. Click on "Show Old" button.
      Profile page shows no information.
      Note: #Issue 3 can be regenerated in whole sfa component party profile screens.

      #Issue 4
      1. Navigate to SFA component https://demo-trunk.ofbiz.apache.org/sfa/control/main.
      2. Click on the Accounts link in sub menu https://demo-trunk-ofbiz.apache.org:8443/sfa/control/FindAccounts.
      3. In "All Accounts" section, Click on partyId link https://demo-trunk-ofbiz.apache.org:8443/sfa/control/viewprofile?roleTypeId=ACCOUNT&partyId=Company.
      4. In the sub-menu, click on "Profile".
      Profile page shows no information.

      #Issue 5
      1. Navigate to SFA component https://demo-trunk.ofbiz.apache.org/sfa/control/main.
      2. Click on the Opportunities link in sub menu https://demo-trunk-ofbiz.apache.org:8443/sfa/control/FindSalesOpportunity.
      3. In the "Find Results" section, click on Lead/Account partyId.
      Profile page shows no information.

      1. Issue2.jpeg
        113 kB
        Parakh Maheshwari
      2. OFBIZ-9512.patch
        5 kB
        Aditya Sharma
      3. OFBIZ-9512.patch
        3 kB
        Aditya Sharma
      4. OFBIZ-9512.patch
        2 kB
        Aditya Sharma
      5. screenshot-1.png
        494 kB
        Jagpreet Kaur

        Activity

        parakh.maheshwari Parakh Maheshwari added a comment -

        Hii jagpreet, I have found the same kind of issue on Contacts Tab of SFA component, so I have edited the ticket description. I have also added steps to regenerate the issue as #Issue2
        Thanks!

        Jagpreet Kaur Jagpreet Kaur added a comment - - edited

        Thanks Parakh for the observation and detailed description of the issue. I have also added #Issue 3

        aditya.sharma Aditya Sharma added a comment -

        There was no roleTypeId in the parameters as list is specific to a relationship there is roleTypeIdTo which can be used with the link.Added a new link with roleTypeId field from roleTypeIdTo.

        aditya.sharma Aditya Sharma added a comment -

        Patch with all issues resolved.
        Added roleTypeId as parameter for ShowOld and HideOld links as it was a required field for viewprofile page.

        Jagpreet Kaur Jagpreet Kaur added a comment -

        Hi Aditya, Thanks for the patch. After applying the patch the functionality works fine.
        Found some more issues in sfa component for profile redirection so, mentioned those in the description as #Issue 4 and #Issue 5.

        devanshu.vyas Devanshu Vyas added a comment -

        Hello Jagpreet,

        Please create a separate ticket for each issue rather than mentioning all in one. This approach is more helpful in issue traceability.
        If all the issues mentioned here are related to a parent one, then create child tickets else create separate tickets.

        Jagpreet Kaur Jagpreet Kaur added a comment - - edited

        Thank you, Devanshu. The reason for creating them all under the same issue is, they have same code fix under different forms.

        aditya.sharma Aditya Sharma added a comment -

        Combined patch for all the 5 issues.
        For Issue 4 & 5 passed roleTypeId as parameter for the link.

        pandeypranay Pranay Pandey added a comment -

        Patch committed to trunk r1806261 and R16.11 at r1806262.

        Thanks Jagpreet Kaur for reporting and verifying the issue, thanks Parakh Maheshwari and Devanshu Vyas for reviewing and providing details on their finding and thanks Aditya for providing the patch.


          People

          • Assignee:
            pandeypranay Pranay Pandey
            Reporter:
            Jagpreet Kaur Jagpreet Kaur
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development