Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-9455

Required check missing for supplier product id and last price on Add Product Supplier page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 16.11.04
    • Component/s: product
    • Labels:

      Description

      Steps to reproduce:
      1. Log in to Catalog component (https://demo-trunk.ofbiz.apache.org/catalog/control/main)
      2. Go to the Products tab. (https://demo-trunk.ofbiz.apache.org/catalog/control/FindProduct)
      3. Find a product and click on id link. (https://demo-trunk.ofbiz.apache.org/catalog/control/EditProduct?productId=WG-9943).
      4. Click on Suppliers subtab.(https://demo-trunk.ofbiz.apache.org/catalog/control/EditProductSuppliers?productId=WG-9943)
      5. Click Create button on Add Product Supplier form.
      No required validation so an error message from the service.

      1. OFBIZ-9455.patch
        1 kB
        Aditya Sharma
      2. screenshot-1.png
        347 kB
        Aditya Sharma

        Activity

        arunpati Arun Patidar added a comment -

        Back ported changes at rev: 1802677

        Thanks Lalit for verifying.

        lalit.kushwah Lalit Kushwah added a comment -

        We can backport the changes to OFBiz-16.11.I have verified with the provided patch.

        mbrohl Michael Brohl added a comment -

        Needs backporting.

        aditya.sharma Aditya Sharma added a comment -

        Thanks, Arun

        arunpati Arun Patidar added a comment -

        Committed in trunk at revision r1801262

        Thanks Aditya sharma for reporting and providing patch.

        aditya.sharma Aditya Sharma added a comment -

        Solution:
        AddProductSupplier form in ProductForms.xml uses auto-field-services for this field due to which there was no required check. Added supplierProductId and lastPrice fields with required-field-true.


          People

          • Assignee:
            arunpati Arun Patidar
            Reporter:
            aditya.sharma Aditya Sharma
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development