Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-9408

Following uiLabels should move from ProductUiLabels.xml to CommonEntityLabels.xml.

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: Trunk
    • Fix Version/s: Upcoming Release
    • Component/s: None
    • Labels:
      None

      Description

      Following uiLabels should move from ProductUiLabels.xml to CommonEntityLabels.xml :

      • ProductShipmentUomAbbreviation_LEN_in
      • ProductShipmentUomAbbreviation_WT_g
      • ProductShipmentUomAbbreviation_WT_kg
      • ProductShipmentUomAbbreviation_WT_lb
        These labels should be written in similer pattern as other labels of "Uom" entity are written in CommonEntityLabels.xml, for example :
        ProductShipmentUomAbbreviation_LEN_in will be written as
        Uom.abbreviation.LEN_in
        <entityName>.<fieldName>.<PrimaryKey>
      1. OFBIZ-9408.patch
        13 kB
        Renuka Srishti
      2. OFBIZ-9408.patch
        11 kB
        Renuka Srishti
      3. OFBIZ-9408.patch
        11 kB
        Renuka Srishti
      4. OFBIZ-9408.patch
        4 kB
        Renuka Srishti

        Activity

        Hide
        Renuka_Srishti Renuka Srishti added a comment -

        Here is the patch for this issue.

        Show
        Renuka_Srishti Renuka Srishti added a comment - Here is the patch for this issue.
        Hide
        jacques.le.roux Jacques Le Roux added a comment -

        Hi Renuka,

        Beware that this is a peculiar case. "uiLabelMap.ProductShipmentUomAbbreviation_" + defaultWeightUomId is used in 2 FTL templates PackOrder.ftl and WeightPackage.ftl. So I agree with the idea but this needs a bit more work

        Show
        jacques.le.roux Jacques Le Roux added a comment - Hi Renuka, Beware that this is a peculiar case. "uiLabelMap.ProductShipmentUomAbbreviation_" + defaultWeightUomId is used in 2 FTL templates PackOrder.ftl and WeightPackage.ftl. So I agree with the idea but this needs a bit more work
        Hide
        Renuka_Srishti Renuka Srishti added a comment -

        Here is the updated patch which covers all the FTL files related to these UiLabel changes.

        Show
        Renuka_Srishti Renuka Srishti added a comment - Here is the updated patch which covers all the FTL files related to these UiLabel changes.
        Hide
        Renuka_Srishti Renuka Srishti added a comment -

        Here is the updated patch which covers all the FTL files related to these UiLabel changes.

        Show
        Renuka_Srishti Renuka Srishti added a comment - Here is the updated patch which covers all the FTL files related to these UiLabel changes.
        Hide
        jacques.le.roux Jacques Le Roux added a comment - - edited

        +1, well done Renuka (did not test, just review)

        Show
        jacques.le.roux Jacques Le Roux added a comment - - edited +1, well done Renuka (did not test, just review)
        Hide
        Renuka_Srishti Renuka Srishti added a comment -

        Thanks, Jacques

        Show
        Renuka_Srishti Renuka Srishti added a comment - Thanks, Jacques
        Hide
        deepak.dixit Deepak Dixit added a comment - - edited

        Hi Renuka,

        I reviewed your patch, it looks good to me.
        Here are some minor improvement that we can include:

        • Add existence check at freemarker side to avoid stack trace
        • I think instead of using uomInfo we can name it more appropriately like defaultUomWeight or defaultWeightUom etc
        • In WeightPackage.ftl you mix the weight uom and dimension.
        • I think we can use abbreviation instead of description.
        Show
        deepak.dixit Deepak Dixit added a comment - - edited Hi Renuka, I reviewed your patch, it looks good to me. Here are some minor improvement that we can include: Add existence check at freemarker side to avoid stack trace I think instead of using uomInfo we can name it more appropriately like defaultUomWeight or defaultWeightUom etc In WeightPackage.ftl you mix the weight uom and dimension. I think we can use abbreviation instead of description.
        Hide
        Renuka_Srishti Renuka Srishti added a comment -

        Thanks Deepak,
        Here is the new updated patch which covers all the improvements suggested by you.

        Show
        Renuka_Srishti Renuka Srishti added a comment - Thanks Deepak, Here is the new updated patch which covers all the improvements suggested by you.
        Hide
        deepak.dixit Deepak Dixit added a comment -

        Thanks Renuka for your contribution
        This has been done at ofbiz framework trunk at r#1801281

        Show
        deepak.dixit Deepak Dixit added a comment - Thanks Renuka for your contribution This has been done at ofbiz framework trunk at r#1801281

          People

          • Assignee:
            deepak.dixit Deepak Dixit
            Reporter:
            Renuka_Srishti Renuka Srishti
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development