Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-9318

Create New Quote button is duplicated on View Quote page

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Trivial
    • Resolution: Implemented
    • Affects Version/s: Release Branch 16.11
    • Fix Version/s: Upcoming Release, 16.11.02
    • Component/s: order
    • Labels:
      None

      Description

      Steps to regenerate:
      1. Go to Order component (https://localhost:8443/ordermgr/control/main)
      2. Click on Quotes submenu (directing to https://localhost:8443/ordermgr/control/FindQuote)
      3. Click on Find button.
      4. Click on any quoteId (directing to https://localhost:8443/ordermgr/control/ViewQuote?quoteId=CQ0001)
      5. Create New Quote button is duplicated.

      With OFBIZ-7841, to make it consistent Create New Quote button added to menu bar so we can remove the other button.

      1. OFBIZ-9318.patch
        0.7 kB
        Aditya Sharma
      2. screenshot-1.png
        334 kB
        Aditya Sharma

        Activity

        aditya.sharma Aditya Sharma added a comment -

        Problem:
        1. "ViewQuote" request directs to "ViewQuote" screen in QuoteScreens.xml.
        2. On ViewQuote screen, it includes "QuoteSubTabBar" from OrderMenus.xml.
        3. "QuoteSubTabBar" has a "Create New Quote" button.

        But as with OFBIZ-7841, to make it consistent Create New Quote button is added to menu bar.

        Solution:
        Removed the button to avoid redundancy.

        jacques.le.roux Jacques Le Roux added a comment -

        Thanks Aditya,

        Your patch is in
        trunk r1791804
        R16.11 r1791805

        For me it's an improvement not a bug. But as it's really better and no risk I backported in last stable

        aditya.sharma Aditya Sharma added a comment -

        Thanks Jacques


          People

          • Assignee:
            jacques.le.roux Jacques Le Roux
            Reporter:
            aditya.sharma Aditya Sharma
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development