Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-9305

change debug.properties property value cause ofbiz can't start

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 16.11.01, 16.11.02
    • Fix Version/s: 16.11.03
    • Component/s: ALL APPLICATIONS
    • Labels:
      None
    • Environment:

      windows 10 x64.

      Description

      change apache-ofbiz-16.11.01\framework\base\config\debug.properties
      print.verbose=false to print.verbose=true
      restart ofbiz with command line:gradlew.bat ofbiz get error happend;

      org.apache.ofbiz.base.util.UtilCodecTests > testCheckStringForHtmlStrictNone STANDARD_OUT
          11:07:31.743 [Test worker] ERROR org.apache.ofbiz.base.util.UtilCodec - Canonicalization (format consistency, character escaping that is mixed or double, etc) error for attribute named [double-encoding], String [%2%353Cscript]: org.apache.ofbiz.base.util.UtilCodec$IntrusionException: Input validation failure
      
      org.apache.ofbiz.entity.util.EntitySaxReaderTests > parse STANDARD_OUT
          11:07:42.509 [Test worker] ERROR org.apache.ofbiz.entity.util.EntitySaxReader - An error occurred saving the data, rolling back transaction (true)
          java.lang.NullPointerException
              at org.apache.ofbiz.entity.util.EntitySaxReader.endElement(EntitySaxReader.java:404) ~[main/:?]
              at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
              at org.apache.xerces.parsers.AbstractXMLDocumentParser.emptyElement(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
              at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElement(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
              at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
              at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
              at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
              at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
              at org.apache.xerces.parsers.XMLParser.parse(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
              at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
              at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
              at org.apache.xerces.jaxp.SAXParserImpl.parse(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
              at javax.xml.parsers.SAXParser.parse(SAXParser.java:195) ~[?:1.8.0_121]
              at org.apache.ofbiz.entity.util.EntitySaxReader.parse(EntitySaxReader.java:225) [main/:?]
              at org.apache.ofbiz.entity.util.EntitySaxReader.parse(EntitySaxReader.java:186) [main/:?]
              at org.apache.ofbiz.entity.util.EntitySaxReaderTests.parse(EntitySaxReaderTests.java:62) [test/:?]
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_121]
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_121]
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_121]
              at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_121]
              at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:45) [junit-dep-4.10.jar:?]
              at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15) [junit-dep-4.10.jar:?]
              at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:42) [junit-dep-4.10.jar:?]
              at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20) [junit-dep-4.10.jar:?]
              at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:263) [junit-dep-4.10.jar:?]
              at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:68) [junit-dep-4.10.jar:?]
              at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:47) [junit-dep-4.10.jar:?]
              at org.junit.runners.ParentRunner$3.run(ParentRunner.java:231) [junit-dep-4.10.jar:?]
              at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:60) [junit-dep-4.10.jar:?]
              at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:229) [junit-dep-4.10.jar:?]
              at org.junit.runners.ParentRunner.access$000(ParentRunner.java:50) [junit-dep-4.10.jar:?]
              at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:222) [junit-dep-4.10.jar:?]
              at org.junit.runners.ParentRunner.run(ParentRunner.java:300) [junit-dep-4.10.jar:?]
              at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassExecuter.runTestClass(JUnitTestClassExecuter.java:112) [gradle-testing-jvm-2.13.jar:2.13]
              at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassExecuter.execute(JUnitTestClassExecuter.java:56) [gradle-testing-jvm-2.13.jar:2.13]
              at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassProcessor.processTestClass(JUnitTestClassProcessor.java:66) [gradle-testing-jvm-2.13.jar:2.13]
              at org.gradle.api.internal.tasks.testing.SuiteTestClassProcessor.processTestClass(SuiteTestClassProcessor.java:51) [gradle-testing-base-2.13.jar:2.13]
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_121]
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_121]
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_121]
              at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_121]
              at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35) [gradle-messaging-2.13.jar:2.13]
              at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24) [gradle-messaging-2.13.jar:2.13]
              at org.gradle.messaging.dispatch.ContextClassLoaderDispatch.dispatch(ContextClassLoaderDispatch.java:32) [gradle-messaging-2.13.jar:2.13]
              at org.gradle.messaging.dispatch.ProxyDispatchAdapter$DispatchingInvocationHandler.invoke(ProxyDispatchAdapter.java:93) [gradle-messaging-2.13.jar:2.13]
              at com.sun.proxy.$Proxy2.processTestClass(Unknown Source) [?:?]
              at org.gradle.api.internal.tasks.testing.worker.TestWorker.processTestClass(TestWorker.java:109) [gradle-testing-base-2.13.jar:2.13]
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_121]
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_121]
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_121]
              at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_121]
              at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35) [gradle-messaging-2.13.jar:2.13]
              at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24) [gradle-messaging-2.13.jar:2.13]
              at org.gradle.messaging.remote.internal.hub.MessageHub$Handler.run(MessageHub.java:364) [gradle-messaging-2.13.jar:2.13]
              at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(ExecutorPolicy.java:54) [gradle-base-services-2.13.jar:2.13]
              at org.gradle.internal.concurrent.StoppableExecutorImpl$1.run(StoppableExecutorImpl.java:40) [gradle-base-services-2.13.jar:2.13]
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_121]
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_121]
              at java.lang.Thread.run(Thread.java:745) [?:1.8.0_121]
      Gradle Test Executor 1 finished executing tests.
      
      org.apache.ofbiz.entity.util.EntitySaxReaderTests > parse FAILED
          org.xml.sax.SAXException: A transaction error occurred reading data
          java.lang.NullPointerException
              at org.apache.ofbiz.entity.util.EntitySaxReader.parse(EntitySaxReader.java:240)
              at org.apache.ofbiz.entity.util.EntitySaxReader.parse(EntitySaxReader.java:186)
              at org.apache.ofbiz.entity.util.EntitySaxReaderTests.parse(EntitySaxReaderTests.java:62)
      
              Caused by:
              java.lang.NullPointerException
                  at org.apache.ofbiz.entity.util.EntitySaxReader.endElement(EntitySaxReader.java:404)
                  at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
                  at org.apache.xerces.parsers.AbstractXMLDocumentParser.emptyElement(Unknown Source)
                  at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElement(Unknown Source)
                  at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
                  at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
                  at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
                  at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
                  at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
                  at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
                  at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
                  at org.apache.xerces.jaxp.SAXParserImpl.parse(Unknown Source)
                  at javax.xml.parsers.SAXParser.parse(SAXParser.java:195)
                  at org.apache.ofbiz.entity.util.EntitySaxReader.parse(EntitySaxReader.java:225)
                  ... 2 more
      

        Activity

        sunose William Wang added a comment -

        ERROR report file

        jacopoc Jacopo Cappellato added a comment -

        Thank you William!
        This issue has been fixed in trunk with revision 1799417 and in 16.03 with revision 1799419


          People

          • Assignee:
            jacopoc Jacopo Cappellato
            Reporter:
            sunose William Wang
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development