Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-9196

Regression: a commit between R15 and the Gradle switch uses/blocks the ports

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Trunk, Release Branch 16.11
    • Fix Version/s: Upcoming Release, 16.11.02
    • Component/s: Gradle
    • Labels:
      None

      Description

      We got an issue on Buildbot because of a Puppet misconfiguration which was always using the port 8080. Pre-gradle OFBiz tests were still running fine on Buildbot.

      Before the Puppet misconfiguration fix by infra (INFRA-13402), to bypass this issue I tried last weekend to use portoffset in Gradle versions. From the documentation, it's theoretically possible but does not work.

      Taher suggested, to get back to the previous behaviour were tests were not using/blocking the 8080 port, and to have a look into Config.java...

      It's a regression because it was nice to not have ports blocked during tests, as it was before Gradle. So you can use another (or more) OFBiz instance while running tests, and vice-versa.

        Activity

        jacques.le.roux Jacques Le Roux added a comment - - edited

        Here are some related threads and issues for those interested
        https://s.apache.org/aR9P
        https://s.apache.org/3uvC
        INFRA-13496
        INFRA-13573

        jacques.le.roux Jacques Le Roux added a comment - - edited

        Ok, this problem persists but at least now tests passes on Buildbot, despite still having the ports owned but by who knows what (see INFRA-13573 about that)

        This trivial problem (not its resolution!) has the only drawback that locally you have to close a trunk or R16.11 running instance before runing tests (from trunk or any other branches)

        jacques.le.roux Jacques Le Roux added a comment -

        We clearly identified the problem locally and it's also a problem on Buildbot because 2 different builds can run on the same machine. See this thread on dev ML https://s.apache.org/RsHI

        jacques.le.roux Jacques Le Roux added a comment -

        Like I answered to Taher in the thread above, we are not yet sure that it's due to changes related to Gradle (refactoring). What we know for sure is branches before R16 have not this problem.

        jacques.le.roux Jacques Le Roux added a comment -

        OK, I locally kept a version of the trunk just prior the Gradle switch.

        When running an OFBiz instance (any one fits, I used the ofbiz-framework+plugin HEAD) you can run tests with R15, but not with this preGradle version. You get

        run-tests:
        [java] org.ofbiz.base.start.StartupException: Couldn't create server socket(/127.0.0.1:10523) (Address already in use: JVM_Bind)Start.java using configuration file org/ofbiz/base/start/test.properties

        So the problem is anterior the Gradle switch and after the R15 freezing.

        But unfortunately we no longer have a trunk to get back into commits. Fortunately we have https://github.com/apache/ofbiz

        I'll try that

        jacques.le.roux Jacques Le Roux added a comment -

        Taher has fixed the bug in trunk at r1787627. We still need to fix the same in R16 branch

        jacques.le.roux Jacques Le Roux added a comment -

        Fixed in R16 branch at r1791513, thanks Taher!


          People

          • Assignee:
            jacques.le.roux Jacques Le Roux
            Reporter:
            jacques.le.roux Jacques Le Roux
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development