Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-8458

Updating Party Content Image does not work

    Details

      Description

      Steps to reproduce -

      • Go to any Party Profile.
      • Add an image from Party Content section.
      • Once image is added, click on the contentId, it will redirect you to the Party Content screen.
      • Click on Edit button and upload a new image.

      Expected - Image should be updated.
      Actual - No changes can be observed, still old image is associated with the content.

      1. OFBIZ-8458.patch
        0.9 kB
        Vishal Chhabria

        Activity

        Hide
        wt Wai added a comment -

        You are correct. They seem to be related.
        Thanks

        Show
        wt Wai added a comment - You are correct. They seem to be related. Thanks
        Hide
        deepak.dixit Deepak Dixit added a comment -

        Thanks Jacques.

        Show
        deepak.dixit Deepak Dixit added a comment - Thanks Jacques.
        Hide
        jacques.le.roux Jacques Le Roux added a comment -

        HI Wai, I believe what you reported is a duplicate of OFBIZ-6709, please check

        Show
        jacques.le.roux Jacques Le Roux added a comment - HI Wai, I believe what you reported is a duplicate of OFBIZ-6709 , please check
        Hide
        wt Wai added a comment -

        This is still no working completely.
        Using trunk
        Go to https://localhost:8443/partymgr/control/viewprofile?partyId=admin
        Upload image, select purpose='logo image url', set public=Y.
        After upload, the content list shows a new entry. As expected.
        The uploaded image is not shown in 'Personal Information' pane though.
        Only after refreshing the page does the image show in the 'Personal Information' pane.

        Show
        wt Wai added a comment - This is still no working completely. Using trunk Go to https://localhost:8443/partymgr/control/viewprofile?partyId=admin Upload image, select purpose='logo image url', set public=Y. After upload, the content list shows a new entry. As expected. The uploaded image is not shown in 'Personal Information' pane though. Only after refreshing the page does the image show in the 'Personal Information' pane.
        Hide
        jacques.le.roux Jacques Le Roux added a comment - - edited

        Fixed both issues at revision: 1766183, only trunk was concerned

        Show
        jacques.le.roux Jacques Le Roux added a comment - - edited Fixed both issues at revision: 1766183, only trunk was concerned
        Hide
        jacques.le.roux Jacques Le Roux added a comment -

        Actually reverting r1765499 would be too much because there are other correct things in there. The 3 tickets for DataResourceType(OFBIZ-8349 OFBIZ-8350 OFBIZ-8351) are OK. So it's only a matter of fixing what I reported above. The easiest is to set createDataResourceRole correctly, I'll do that now

        BTW a ticket for CreateDataResourceRole seems to miss so I could not mark it as breaking this issue (regression).

        Show
        jacques.le.roux Jacques Le Roux added a comment - Actually reverting r1765499 would be too much because there are other correct things in there. The 3 tickets for DataResourceType( OFBIZ-8349 OFBIZ-8350 OFBIZ-8351 ) are OK. So it's only a matter of fixing what I reported above. The easiest is to set createDataResourceRole correctly, I'll do that now BTW a ticket for CreateDataResourceRole seems to miss so I could not mark it as breaking this issue (regression).
        Hide
        jacques.le.roux Jacques Le Roux added a comment - - edited

        This is due to http://svn.apache.org/viewvc?view=revision&revision=1765499. Before createDataResourceRole accepted an empty fromDate and set it to now in this case. Also there are errors in the new auto-engine definition: UPDATE permission is used for the 3 cases. I tried to revert r1765499 but there is a conflict, I guess due to more recent changes. Please Deepak Dixit could you handle it?

        Show
        jacques.le.roux Jacques Le Roux added a comment - - edited This is due to http://svn.apache.org/viewvc?view=revision&revision=1765499 . Before createDataResourceRole accepted an empty fromDate and set it to now in this case. Also there are errors in the new auto-engine definition: UPDATE permission is used for the 3 cases. I tried to revert r1765499 but there is a conflict, I guess due to more recent changes. Please Deepak Dixit could you handle it?
        Hide
        wt Wai added a comment -

        Please reopen this issue.

        Tested it with trunk.
        Go to https://localhost:8443/partymgr/control/viewprofile?partyId=admin
        Upload image for logo, set to public=Y
        After upload, image is not shown in 'Personal Information' pane.
        In addition, the content list does not show any images uploaded.
        Even after refresh of page, no image shown.

        Show
        wt Wai added a comment - Please reopen this issue. Tested it with trunk. Go to https://localhost:8443/partymgr/control/viewprofile?partyId=admin Upload image for logo, set to public=Y After upload, image is not shown in 'Personal Information' pane. In addition, the content list does not show any images uploaded. Even after refresh of page, no image shown.
        Hide
        jacques.le.roux Jacques Le Roux added a comment -

        Thanks Vishal,

        Your patch is in
        trunk r1765108
        R15.12, 14.12, 13.07 r1765109

        Show
        jacques.le.roux Jacques Le Roux added a comment - Thanks Vishal, Your patch is in trunk r1765108 R15.12, 14.12, 13.07 r1765109
        Hide
        vishal.chhabria Vishal Chhabria added a comment -

        Adding Patch for the fix.
        Uploaded file data and file name was not passed to the updateContentAndUploadedFile service hence dataResource was not updated with new image path and dataResourceName.

        Show
        vishal.chhabria Vishal Chhabria added a comment - Adding Patch for the fix. Uploaded file data and file name was not passed to the updateContentAndUploadedFile service hence dataResource was not updated with new image path and dataResourceName.

          People

          • Assignee:
            jacques.le.roux Jacques Le Roux
            Reporter:
            vishal.chhabria Vishal Chhabria
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development